Bug 19239 - problem with the upgrade from 6.2 to 7.0 on mirroring on Fujistu-siemens 170
Summary: problem with the upgrade from 6.2 to 7.0 on mirroring on Fujistu-siemens 170
Status: CLOSED DUPLICATE of bug 18900
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 09:23 UTC by Need Real Name
Modified: 2007-03-27 03:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 21:35:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error upgrade (2.42 KB, text/plain)
2000-10-17 09:26 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-10-17 09:23:21 UTC
when i tried to upgrade my primergy f-s 170 the O.S. told me this:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", 
line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File 
"/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 412, in nextClicked
    next = self.currentScreen.getNext ()
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line 19, in getNext
    self.todo.upgradeFindPackages (self.root)
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 910, in upgradeFindPackages
    fstab.readFstab('/mnt/sysimage/etc/fstab', 
self.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 1028, in readFstab
    fields[2], raidByDev[int(fields[0][7:])])
KeyError: 3

Local variables in innermost frame:
loopIndex: {}
fstab: <fstab.GuiFstab instance at 8532dd8>
labelsByMount: {}
line: 
/dev/md3                /w1                   ext2    defaults        1 2

path: /mnt/sysimage/etc/fstab
raidByDev: {2: ['sda5', 'sdb5'], 1: ['sda1', 
'sdb1'], 
0: ['sda6', 'sdb6']}
devList: ['sda6', 'sdb6']
mdDev: 0
drives: ['sda', 'sdb']
lines: ['/dev/md1                /                       ext2    defaults        1 
1\012', '/dev/md0                /boot                   ext2    defaults        1 2\012', '/dev/md3                /w1                   ext2    defaults        1 2\012', 
'/dev/md4                /w2                   ext2    defaults        1 2\012', '/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0\012', 
'/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0\012', 'none                    /proc                   proc    defaults        0 0\012', 
'none                    /dev/pts                devpts  gid=5,mode=620  0 0\012', '/dev/md2                swap                    swap    defaults        0 
0\012']
labels: {}
fields: ['/dev/md3', '/w1', 'ext2', 'defaults', '1', '2']
f: <open file '/mnt/sysimage/etc/fstab', mode 'r' at 853a908>
raidList: [(2, 
['sda5', 'sdb5']), (1, ['sda1', 'sdb1']), (0, ['sda6', 'sdb6'])]

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

thanks

Comment 1 Need Real Name 2000-10-17 09:26:05 UTC
Created attachment 4252 [details]
error upgrade

Comment 2 Michael Fulbright 2000-10-19 21:35:29 UTC

*** This bug has been marked as a duplicate of 18900 ***


Note You need to log in before you can comment on or make changes to this bug.