Bug 192393 - powernow-k8 (nforce3) enabled on 2.6.9-11.EL but not a in 2.6.9-34.EL
powernow-k8 (nforce3) enabled on 2.6.9-11.EL but not a in 2.6.9-34.EL
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-19 05:55 EDT by Jose Plans
Modified: 2008-09-25 02:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 02:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/cpuinfo : hardware.py (10.02 KB, text/plain)
2006-05-19 05:55 EDT, Jose Plans
no flags Details
cpuspeed.conf (624 bytes, application/octet-stream)
2006-05-19 05:56 EDT, Jose Plans
no flags Details
boot description with 2.6.9-34.EL i686 athlon i386 (12.56 KB, text/plain)
2006-05-19 05:57 EDT, Jose Plans
no flags Details
boot description with 2.6.9-11.EL i686 athlon i386 [powernow-k8 ok] (24.30 KB, text/plain)
2006-05-19 05:59 EDT, Jose Plans
no flags Details

  None (edit)
Description Jose Plans 2006-05-19 05:55:15 EDT
This customer has a laptop using AMD64 and nforce3 chipsets, when he installed
RHEL4U1, he could benefit from powernow-k8, but since he installed the latest
kernel 2.6.9-34.EL, that was not the case anymore. However, this only happens on
the i686 version of the kernel, not for the x86_64 which launches succesfully
the module and allows the user to benefit from cpu_freq.

 Unfortunately we can't perform further tests as the customer decided to install
another OS to benefit from it, I'm escalating this to warn from a possible
regression on this field. 
 With kernel 2.6.9-11.EL 32bit we get a successful powernow-k8 install :
 ---
kernel: powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09b)
kernel: powernow-k8:    0 : fid 0xa (1800 MHz), vid 0x2 (1500 mV)
kernel: powernow-k8:    1 : fid 0x8 (1600 MHz), vid 0x6 (1400 mV)
kernel: powernow-k8:    2 : fid 0x0 (800 MHz), vid 0x12 (1100 mV)
kernel: powernow-k8: cpu_init done, current fid 0x8, vid 0x6
 ---

 With kernel 2.6.9-34.EL 32bit :
 ---
'/lib/modules/2.6.9-34.EL/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k8.ko':
-1 No such device
 ---

Thanks,
Comment 1 Jose Plans 2006-05-19 05:55:15 EDT
Created attachment 129588 [details]
/proc/cpuinfo : hardware.py
Comment 2 Jose Plans 2006-05-19 05:56:22 EDT
Created attachment 129589 [details]
cpuspeed.conf
Comment 3 Jose Plans 2006-05-19 05:57:51 EDT
Created attachment 129590 [details]
boot description with 2.6.9-34.EL i686 athlon i386
Comment 4 Jose Plans 2006-05-19 05:59:18 EDT
Created attachment 129591 [details]
boot description with 2.6.9-11.EL i686 athlon i386 [powernow-k8 ok]

Note You need to log in before you can comment on or make changes to this bug.