Bug 192394 - Permissions problem when installing langauges other than English (US) on Thunderbird.
Permissions problem when installing langauges other than English (US) on Thun...
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2006-05-19 06:10 EDT by Chris Neville-Smith
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-23 05:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Neville-Smith 2006-05-19 06:10:15 EDT
Description of problem:

When I tried to install English (GB) using the introctions on the front page in
Thunderbird, although it claimed the language pack was successfully installed,
nothing actually happened. I managed to install it running Thunderbird as root,
but when I went back to User, although English (GB) was on offer, when selected
it considered every word a spelling mistake.

When I finally tracked down the problem, it was because the permissions for the
English (GB) files were set to read only for root, and nothing at all for anyone
else. I changed the permissions and it now works fine, but this is a pretty
hefty workaround for something that seems relatively easy to fix.

Version-Release number of selected component (if applicable):

How reproducible:

Probably always, but can't confirm this. (Not fiddling with my language settings
have gone through all this trouble to get it right.)

Steps to Reproduce:
1. Open Thunderbird when your locale is set to something other than English (US).
2. Click on the line at the bottom to install the dictionary (in my case,
English GB).
3. Thunderbird pretends it's installing the dictionary.
Actual results:

Either nothing, or English (GB) available on menu but no words in it (unless you
work as root).

Expected results:

Language available, no fuss.

Additional info:
Comment 1 Matěj Cepl 2007-07-18 13:27:53 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 2 Chris Neville-Smith 2007-07-21 14:22:17 EDT
Okay, just tried it on Fedora 7, and it works fine. It's not the most obvious
way of installing an extension, but that's another story.

Thanks to whoever fixed it.

Note You need to log in before you can comment on or make changes to this bug.