Bug 19242 - Attempts to install the Perl module "Bundle::PlRPC" 0.2012 fail
Summary: Attempts to install the Perl module "Bundle::PlRPC" 0.2012 fail
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 10:00 UTC by Matt Johnson
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 11:01:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Johnson 2000-10-17 10:00:00 UTC
Hi,

I am unable to install a Perl module called Bundle::PlRPC onto my RedHat 
7.0 machine, either manually or through CPAN.pm.  When running the "make 
test", it reports the error shown at the end of this description.  

Reinstalls of RedHat/CPAN/Perl do not cure the problem.  I have seen other 
reports of this exact problem on UseNet, but no fixes (as yet).  PlRPC 
installs fine on other platforms (Solaris, etc); I've been unable to test 
it on previous versions of RedHat.

This is a fairly major issue, since many Perl modules have a PlRPC 
dependancy.

Regards,
Matt

[root@e010 PlRPC-0.2012]# make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -
I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 -e 'use 
Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
t/base..............ok                                                     
  
t/client............Use of uninitialized value in concatenation (.) at 
t/lib.pl line 30.
Use of uninitialized value in concatenation (.) at t/lib.pl line 31.
Use of uninitialized value in concatenation (.) at t/lib.pl line 32.
t/client............NOK 10FAILED tests 1-
10                                  
        Failed 10/10 tests, 0.00% okay
t/compress..........Use of uninitialized value in concatenation (.) at 
t/lib.pl line 30.
Use of uninitialized value in concatenation (.) at t/lib.pl line 31.
Use of uninitialized value in concatenation (.) at t/lib.pl line 32.
Use of uninitialized value in concatenation (.) at t/lib.pl line 30.
Use of uninitialized value in concatenation (.) at t/lib.pl line 31.
Use of uninitialized value in concatenation (.) at t/lib.pl line 32.
t/compress..........NOK 18FAILED tests 1-
18                                  
        Failed 18/18 tests, 0.00% okay
t/crypt.............skipped test on this platform
t/methods...........Use of uninitialized value in concatenation (.) at 
t/lib.pl line 30.
Use of uninitialized value in concatenation (.) at t/lib.pl line 31.
Use of uninitialized value in concatenation (.) at t/lib.pl line 32.
t/methods...........ok 11/11FAILED tests 1-
9                                 
        Failed 9/11 tests, 18.18% okay
Failed Test  Status Wstat Total Fail  Failed  List of failed
---------------------------------------------------------------------------
----
t/client.t                   10   10 100.00%  1-10
t/compress.t                 18   18 100.00%  1-18
t/methods.t                  11    9  81.82%  1-9
1 test skipped.
Failed 3/5 test scripts, 40.00% okay. 37/42 subtests failed, 11.90% okay.
make: *** [test_dynamic] Error 29

Comment 1 Chip Turner 2002-05-13 17:57:18 UTC
is this still an issue with the latest red hat release, 7.3?

Comment 2 Warren Togami 2005-09-11 11:01:07 UTC
Closing due to lack of activity and unsupported product.


Note You need to log in before you can comment on or make changes to this bug.