Bug 19248 - upgrade to 7.0 from 6.2 on i386 fails via FTP install
upgrade to 7.0 from 6.2 on i386 fails via FTP install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 09:19 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 12:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-17 09:19:27 EDT
the anaconda program spit out a message before it died saying that this
dump ought to be brought to your attention, so I opened this trouble
ticket.  I call it low severity, since I can stand up a new 7.0 stage in a
couple of hours, but this might affect some possibly less skilled folks,
causing confusion.

Notes: Original zoot install done via FTP, botting from the bootnet.img. 
7.0 upgrade attempted via FTP install, booting from 7.0's bootnet.img. 
Process went smooth up until the RPM's were going to be upgraded, and then
anaconda produced the following dump.  Hardware is a crappy Dell Optiplex
GX1 (p3 450, all IDE, ATAPI CDROM, 3com NIC (3c9??), 128MB).

-----BEGIN ANACONDA DUMP-----
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1526, in
doInstall
IOError: [Errno 2] No such file or directory:
'/mnt/sysimage/tmp/upgrade.log'

Local variables in innermost frame:
arch: i386
total: 487
msg: File exists
logname: /tmp/upgrade.log
i: /etc/X11
p: wmconfig
l: [anacron, anonftp, apache, apmd, arpwatch, ash, aspell, at, audiofile,
audiofile-devel, aumix, authconfig, autoconf, automake, autorun, awesfx,
basesystem, bash, bc, bdflush, bind-utils, binutils, bison, bug-buddy,
byacc, bzip2, bzip2-devel, cdecl, cdp, chkconfig, chkfontpath, cleanfeed,
compat-egcs, compat-egcs-c++, compat-glibc, compat-libstdc++,
console-tools, control-center, control-center-devel, control-panel, cpio,
cpp, cproto, cracklib, cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl,
db1, db1-devel, db2, db3, desktop-backgrounds, dev, dev86, dhcpcd,
diffstat, diffutils, dosfstools, dump, e2fsprogs, ed, ee, eject,
ElectricFence, elm, emacs, emacs-X11, esound, esound-devel, exmh, expect,
extace, fetchmail, file, filesystem, fileutils, findutils, finger,
finger-server, flex, fortune-mod, freetype, ftp, gawk, gcc, gcc-c++,
gcc-g77, gcc-objc, gd, gd-devel, gdb, gdbm, gdbm-devel, gdk-pixbuf, gdm,
gedit, gettext, gftp, ghostscript, ghostscript-fonts, gimp, gimp-devel,
glade, glib, glib-devel, glibc, glibc-devel, gmc, gmp, gnome-applets,
gnome-audio, gnome-audio-extra, gnome-core, gnome-core-devel, gnome-games,
gnome-games-devel, gnome-libs, gnome-libs-devel, gnome-linuxconf,
gnome-media, gnome-objc, gnome-objc-devel, gnome-pim, gnome-pim-devel,
gnome-print, gnome-users-guide, gnome-utils, gnorpm, gnotepad+, gnuchess,
gnumeric, gnupg, gpm, gpm-devel, gqview, grep, groff, groff-perl, gtk+,
gtk+-devel, gtk-engines, gtop, guile, gv, gzip, hdparm, ical, ImageMagick,
imlib, imlib-cfgeditor, imlib-devel, indent, indexhtml, inews, info,
initscripts, inn, ipchains, iproute, iputils, irda-utils, isapnptools,
kbdconfig, kdebase, kdegames, kdegraphics, kdelibs, kdelibs-devel,
kdemultimedia, kdenetwork, kdesupport, kdesupport-devel, kdetoys, kdeutils,
kernel, kernel-headers, kernel-pcmcia-cs, kernel-source, kernel-utils,
kernelcfg, kgcc, krb5-devel, krb5-libs, kudzu, kudzu-devel, less, libghttp,
libghttp-devel, libglade, libglade-devel, libgtop, libgtop-devel, libjpeg,
libjpeg-devel, libpng, libpng-devel, librep, libstdc++, libstdc++-devel,
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool,
libtool-libs, libungif, libungif-devel, libxml, libxml-devel, lilo,
linuxconf, linuxconf-devel, logrotate, losetup, LPRng, lsof, ltrace, lynx,
m4, magicdev, mailcap, mailx, make, MAKEDEV, man, man-pages, mc, memprof,
Mesa, Mesa-devel, metamail, mikmod, mingetty, mkbootdisk, mkinitrd, mktemp,
mkxauth, mod_perl, modemtool, modutils, mount, mouseconfig, mpage, mpg123,
mt-st, mtools, multimedia, mutt, ncftp, ncompress, ncurses, ncurses-devel,
ncurses4, net-tools, netcfg, netpbm, netpbm-devel, netpbm-progs,
netscape-common, netscape-communicator, newt, newt-devel, nfs-utils, nmh,
ntsysv, openjade, openldap, openssl, ORBit, ORBit-devel, pam, passwd,
patch, pciutils, pciutils-devel, perl, pidentd, pilot-link,
pilot-link-devel, pine, playmidi, playmidi-X11, pmake, pnm2ppa, popt,
portmap, printtool, procmail, procps, psmisc, pspell, pump, pwdb, pygnome,
pygnome-libglade, pygtk, pygtk-libglade, python, python-xmlrpc, pythonlib,
qt, qt-devel, qt1x, qt1x-devel, quota, raidtools, rcs, rdate, readline,
readline-devel, redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome,
rep-gtk-libglade, rhn_register, rhn_register-gnome, rhs-printfilters, rmt,
rootfiles, rpm, rpm-build, rpm-devel, rpm-python, rsh, rsh-server, rsync,
rusers, rusers-server, rwall-server, rwho, rxvt, samba, samba-client,
samba-common, sash, sawfish, screen, sed, sendmail, setserial, setup,
setuptool, sgml-common, sgml-tools, sh-utils, shadow-utils, shapecfg,
sharutils, slang, slang-devel, slocate, slrn, sndconfig, sox, stat, strace,
switchdesk, switchdesk-gnome, switchdesk-kde, sysklogd, SysVinit, talk,
talk-server, tar, tcl, tclx, tcp_wrappers, tcsh, telnet, telnet-server,
termcap, tetex-fonts, tetex-xdvi, texinfo, textutils, tftp-server, time,
timeconfig, timetool, tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute,
trn, trojka, umb-scheme, unzip, up2date, up2date-gnome, urlview, urw-fonts,
usermode, utempter, util-linux, vim-common, vim-minimal, vixie-cron, which,
whois, words, wu-ftpd, Xaw3d, Xaw3d-devel, xbill, xboard, xboing, xchat,
Xconfigurator, XFree86, XFree86-3DLabs, XFree86-75dpi-fonts, XFree86-8514,
XFree86-AGX, XFree86-devel, XFree86-doc, XFree86-FBDev, XFree86-I128,
XFree86-libs, XFree86-Mach32, XFree86-Mach64, XFree86-Mach8, XFree86-Mono,
XFree86-P9000, XFree86-S3, XFree86-tools, XFree86-twm, XFree86-xdm,
XFree86-xfs, xgammon, xinetd, xinitrc, xjewel, xloadimage, xmailbox, xmms,
xmorph, xpaint, xpat2, xpdf, xpilot, xpuzzles, xrn, xscreensaver, xsri,
xtrojka, xxgdb, yp-tools, ypbind, ypserv, zip, zlib, zlib-devel, db2-devel,
db3-devel, db3-utils, enlightenment, fnlib, fnlib-devel, freetype-devel,
fvwm2, fvwm2-icons, getty_ps, glib10, gtk+10, ircii, kdeadmin,
kdebase-lowcolor-icons, kdoc, kdpms, korganizer, kpackage, kpilot, lam,
libxml10, openldap-clients, openldap-servers, php, pvm, pvm-gui,
readline2.2.1, wmconfig]
db: <rpmdb object at 8c294c8>
self: <todo.ToDo instance at 826a250>
how: u
errno: 17
totalSize: 1122324
f: <closed file '/mnt/sysimage/etc/mtab', mode 'w+' at 8c1bfc0>
ts: <rpmtrans object at 921fee8>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://19.91.98.78/pub/redhat7'
sbsS'initlevel'
p7
I3
sS'skipLilo'
p8
I0
sS'progressWindow'
p9
NsS'expert'
p10
I1
sS'ddruidReadOnly'
p11
I0
sS'bootdisk'
p12
I0
sS'language'
p13
(itodo
Language
(dp14
S'abbrevMap'
p15
(dp16
S'es_ES'
p17
S'Spanish'
p18
sS'tr_TR'
p19
S'Turkish'
p20
sS'sr_YU'
p21
S'Serbian'
p22
sS'de_DE'
p23
S'German'
p24
sS'sk_SK'
p25
S'Slovak'
p26
sS'ru_RU.KOI8-R'
p27
S'Russian'
p28
sS'is_IS'
p29
S'Icelandic'
p30
sS'no_NO'
p31
S'Norwegian'
p32
sS'sv_SE'
p33
S'Swedish'
p34
sS'en_US'
p35
S'English'
p36
sS'it_IT'
p37
S'Italian'
p38
sS'da_DK'
p39
S'Danish'
p40
sS'cs_CZ'
p41
S'Czech'
p42
sS'uk_UA.KOI8-U'
p43
S'Ukrainian'
p44
sS'hu_HU'
p45
S'Hungarian'
p46
sS'fr_FR'
p47
S'French'
p48
sS'sl_SI'
p49
S'Slovenian'
p50
sS'ro_RO'
p51
S'Romanian'
p52
ssS'font'
p53
(dp54
g38
S'lat0-sun16'
sg22
S'cyr-sun16'
sg28
S'cyr-sun16'
sg36
S'None'
sg26
S'lat2-sun16'
sg32
S'lat0-sun16'
sg34
S'lat0-sun16'
sg48
S'None'
sg50
S'lat2-sun16'
sg52
S'lat2-sun16'
sg24
S'None'
sg20
S'lat5-sun16'
sg46
S'lat2-sun16'
sg18
S'None'
sg44
S'cyr-sun16'
sg42
S'lat2-sun16'
sg40
S'lat0-sun16'
sg30
S'lat0-sun16'
ssS'langs'
p55
(dp56
g38
g37
sg22
g21
sg28
g27
sg36
g35
sg26
g25
sg32
g31
sg34
g33
sg48
g47
sg50
g49
sg52
g51
sg24
g23
sg20
g19
sg46
g45
sg18
g17
sg44
g43
sg42
g41
sg40
g39
sg30
g29
ssS'info'
p57
(dp58
S'LANG'
p59
g35
ssS'map'
p60
(dp61
g38
S'iso15'
sg22
S'iso05'
sg28
S'koi8-r'
sg36
S'None'
sg26
S'iso02'
sg32
S'iso15'
sg34
S'iso15'
sg48
S'None'
sg50
S'iso02'
sg52
S'iso02'
sg24
S'None'
sg20
S'iso09'
sg46
S'iso02'
sg18
S'None'
sg44
S'koi8-u'
sg42
S'iso02'
sg40
S'iso15'
sg30
S'iso15'
ssS'lang'
p62
g35
sbsS'fstab'
p63
NsS'lilo'
p64
(ililo
LiloConfiguration
(dp65
S'liloDevice'
p66
S'partition'
p67
sS'initrdsMade'
p68
(dsS'edd'
p69
I0
sS'default'
p70
S'linux'
p71
sS'liloImages'
p72
(dp73
S'hda2'
p74
(g71
I2
tssS'liloLinear'
p75
I1
sS'liloAppend'
p76
NsbsS'instLogName'
p77
S'/mnt/sysimage/tmp/upgrade.log'
sS'comps'
p78
NsS'network'
p79
(itodo
Network
(dp80
S'netdevices'
p81
(dp82
S'eth0'
p83
(itodo
NetworkDevice
(dp84
g57
(dp85
S'ONBOOT'
p86
S'yes'
sS'IPADDR'
p87
S'19.91.99.213'
sS'BOOTPROTO'
p88
S'static'
sS'NETMASK'
p89
S'255.255.254.0'
sS'DEVICE'
p90
g83
ssbssS'gateway'
p91
S'19.91.98.1'
sS'secondaryNS'
p92
S''
sS'hostname'
p93
S'localhost.localdomain'
p94
sS'primaryNS'
p95
S'19.91.98.21'
sS'domains'
p96
(lsS'isConfigured'
p97
I1
sS'readData'
p98
I1
sS'ternaryNS'
p99
S''
sbsS'upgrade'
p100
I1
sS'instClass'
p101
(iinstallclass
DefaultInstall
p102
(dp103
S'rootPasswordCrypted'
p104
I0
sS'nameserver'
p105
S''
sS'x'
NsS'rootPassword'
p106
NsS'makeBootdisk'
p107
I0
sS'installType'
p108
NsS'postScript'
p109
NsS'earlySwapOn'
p110
I0
sS'networkDevice'
p111
NsS'clearText'
p112
Nsg64
(S'mbr'
p113
I1
S''
tsg13
S'en_US'
p114
sS'name'
p115
S''
sS'postInChroot'
p116
I0
sS'pixmap'
p117
S''
sS'partitions'
p118
(lsS'clearType'
p119
Nsg91
S''
sS'mouse'
p120
NsS'packages'
p121
NsS'timezone'
p122
NsS'zeroMbr'
p123
I0
sS'keyboard'
p124
S'us'
p125
sS'groups'
p126
NsS'bootProto'
p127
NsS'netmask'
p128
S''
sS'raidList'
p129
(lsS'skipSteps'
p130
(dp131
g124
I1
sg13
I1
ssS'auth'
p132
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg93
Nsg63
(lsS'showgroups'
p133
NsS'ip'
p134
S''
sS'defaultRunlevel'
p135
NsS'desktop'
p136
S''
sS'clearPartText'
p137
NsS'clearParts'
p138
I0
sbsS'dbpath'
p139
S'/var/lib/anaconda-rebuilddb971773357'
sS'rootpassword'
p140
NsS'extraModules'
p141
(lp142
sg120
(imouse
Mouse
p143
(dp144
S'device'
p145
S'psaux'
p146
sg57
(dp147
S'XMOUSETYPE'
p148
S'PS/2'
p149
sS'FULLNAME'
p150
S'Generic - 3 Button Mouse (PS/2)'
p151
sS'MOUSETYPE'
p152
S'ps/2'
p153
ssS'emu'
p154
I0
sS'wasProbed'
p155
I1
sS'emulate'
p156
I0
sbsS'ddruidAlreadySaved'
p157
I0
sS'serial'
p158
I0
sg122
Nsg123
I0
sg124
(ikbd
Keyboard
(dp159
S'layout'
p160
NsS'model'
p161
NsS'type'
p162
S'PC'
p163
sg57
(dp164
S'KEYBOARDTYPE'
p165
S'pc'
p166
sS'KEYTABLE'
p167
g125
ssbsS'fdDevice'
p168
S'fd0'
p169
sS'installSystem'
p170
I1
sS'setupFilesystems'
p171
I1
sg132
(itodo
Authentication
(dp172
S'useNIS'
p173
I0
sS'nisServer'
p174
S''
sS'useLdap'
p175
I0
sS'krb5Kdc'
p176
S''
sS'useHesiod'
p177
I0
sS'ldapServer'
p178
S''
sS'nisDomain'
p179
S''
sS'krb5Realm'
p180
S''
sS'useLdapauth'
p181
I0
sS'hesiodRhs'
p182
S''
sS'useShadow'
p183
I1
sS'nisuseBroadcast'
p184
I0
sS'useKrb5'
p185
I0
sS'useMD5'
p186
I1
sS'ldapBasedn'
p187
S''
sS'krb5Admin'
p188
S''
sS'hesiodLhs'
p189
S''
sS'hesiodDlhs'
p190
S''
sbsg93
NsS'reconfigOnly'
p191
I0
sS'x'
(ixf86config
XF86Config
(dp192
S'monlist'
p193
(dsS'keyModel'
p194
S'pc101'
p195
sS'monids'
p196
(dsg145
NsS'monEisa'
p197
NsS'server'
p198
NsS'monHoriz'
p199
S'31.5'
p200
sS'devID'
p201
NsS'modes'
p202
(dp203
S'8'
(lp204
S'640x480'
p205
assS'keyOptions'
p206
S''
sS'keyVariant'
p207
S''
sS'monID'
p208
S'Unprobed Monitor'
p209
sS'keyLayout'
p210
S'us'
p211
sS'manualModes'
p212
(dsg120
g143
sS'keyRules'
p213
S'xfree86'
p214
sS'monVert'
p215
S'60'
p216
sS'cardMan'
p217
NsS'monSect'
p218
S''
sS'primary'
p219
I0
sS'vidRam'
p220
NsS'probed'
p221
I0
sS'monName'
p222
NsS'vidCards'
p223
(lsS'skip'
p224
I0
sS'files'
p225
S'\012# The location of the RGB database.  Note, this is the name of
the\012# file minus the extension (like ".txt" or ".db").  There is
normally\012# no need to change the default.\012\012   
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and
later now use a font server independent of\012# the X server to render
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012   
FontPath   "unix/:7100"\012'
p226
sbsS'users'
p227
NsS'instPath'
p228
S'/mnt/sysimage'
p229
sS'intf'
p230
NsS'hdList'
p231
-----END ANACONDA DUMP-----
Comment 1 Michael Fulbright 2000-10-19 17:38:56 EDT
Is your /tmp directory a symlink?

This will cause problems if so.
Comment 2 Need Real Name 2000-10-24 12:41:36 EDT
Yep, /tmp was a symlink.  *sheesh*  Shame on me for not noticing that. 
Especially since my main workstation is Solaris--having a symlink for /tmp would
never fly there.  Anyway, many thanks for pointing out my error.  Got Guiness
running smooth now, upgraded from Zoot.  Again, many thanks.
Comment 3 Michael Fulbright 2000-10-27 16:32:06 EDT
No problem, glad its working now.

Note You need to log in before you can comment on or make changes to this bug.