Bug 19250 - Installer unable to find (detected!) SCSI CD-R
Installer unable to find (detected!) SCSI CD-R
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 09:35 EDT by paluch
Modified: 2007-03-26 23:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 15:01:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paluch 2000-10-17 09:35:53 EDT
Installer (boot.img) is unable to deal with SCSI CDROM (or at least CD-R
device).
This is probably anaconda bug. Tested on RedHat 7.0 (RedHat 4.0 worked fine
:-)

On startup it successfuly loads 'aic7xxx' module and kernel messages show
that
SCSI disks & CD-ROM were detected. However it does not mount that image
automatically.
It still asks for SCSI/non-scsi CD-ROM type. When SCSI is selected it wants
to load
additional SCSI module (but that CD-ROM was already detected on aic7xxx
module).
So it is impossible to install directly from local SCSI CD-ROM.

Hardware is:
 Pentium Pro/200MHz, 128MB RAM
 Adaptec 2940 dual channel
 2xLVD  4GB SCSI disks
 YAMAHA SCSI CDR102 (CD-R)

This hardware otherwise works well (including CD-R(OM) device) on RedHat
4.0 :-) with 2.0.36 kernel.
Comment 1 Michael Fulbright 2000-10-19 17:40:05 EDT
Please reproduce.
Comment 2 paluch 2000-10-21 08:21:06 EDT
I reproduced the problem and found possible cause:
Kernel reports 'Type:' as 'CD-ROM' for SCSI CD-ROM. However it reports 'WORM'
for CD-R device. I *GUESS*, that this could confuse Anaconda install (the older
C install worked fine).
Here are tested RedHat's boot.img's:
RedHat 4.2, 6.0 - OK
RedHat 6.1, 6.2, 7.0 - FAILS - it forces me to load additional SCSI modules
(when choosed
CD-ROM type - SCSI), although that device was already detected by kernel.
Comment 3 paluch 2000-10-21 09:01:30 EDT
I looked into
/RedHat/instimage/usr/lib/anaconda/_isys.so
and found only 'CD-ROM' keyword near some SCSI keywords. But not 'WORM'. Could
anybody try to add this keyword? (I do not know, how and from what build
boot.img disk).

Comment 4 Michael Fulbright 2000-10-27 16:33:05 EDT
I'm sorry - I meant for our QA person Brock to reproduce here in our test lab.

My apologies!
Comment 5 Brock Organ 2000-11-02 10:41:25 EST
although I could not reproduce this here in our test lab with our closest
hardware (a yamaha CRW8424S on an AHA-294x adapter), other evidence shows this
problem to exist:

http://www.sslug.dk/emailarkiv/teknik/2000_01/msg00368.html

Here is an excerpt from that message:

Det mest underlige af det her er at det har virket.

Jan  8 10:58:37 linux kernel: Configuring Adaptec (SCSI-ID 7) at IO:330, IRQ 11,
DMA priority 5 
Jan  8 10:58:37 linux kernel: scsi0 : Adaptec 1542 
Jan  8 10:58:37 linux kernel: scsi : 1 host. 
Jan  8 10:58:38 linux kernel:   Vendor: YAMAHA    Model: CDR102            Rev:
1.00 
Jan  8 10:58:38 linux kernel:   Type:   WORM                               ANSI
SCSI revision: 02 
Jan  8 10:58:38 linux kernel: Detected scsi CD-ROM sr0 at scsi0, channel 0, id
4, lun 0 

And, yes, the "Type" value for this drive is listed "WORM" ...

one of two possibilities for working around this situation:

1) modify anaconda to try to work with type "WORM"
2) modify the kernel to report "CDROM" instead of "WORM"

(of course, it is not clear why "WORM" is reported in the first place ... :) )

thanks for your report!
Comment 6 Brock Organ 2000-11-02 10:42:36 EST
this issue (verified) is assigned to a developer for further action ...
Comment 7 Bill Nottingham 2000-12-08 15:01:32 EST
Fixed in kudzu-0.83-1, and therefore fixed in whatever version of the installer
will be built after that.
Comment 8 Brock Organ 2000-12-11 15:46:28 EST
as we don't have a CDR in our test lab with this problem, we haven't verified
the fix or observed the bad behavior, but please reopen if this is not resolved
in the next release ...

Note You need to log in before you can comment on or make changes to this bug.