Bug 1925138 - QJackCtl does not start and reports an error.
Summary: QJackCtl does not start and reports an error.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-04 13:33 UTC by Lukas Ruzicka
Modified: 2021-02-06 01:18 UTC (History)
7 users (show)

Fixed In Version: pipewire-0.3.21-2.fc34 pipewire-0.3.21-2.eln109 pipewire-0.3.21-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-04 16:55:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2021-02-04 13:33:59 UTC
Description of problem:

On latest Rawhide, the qjackctl does not start with a following error:

qjackctl: symbol lookup error: qjackctl: undefined symbol: jack_session_commands_free

The system is running PipeWire with PipeWire's implementation of jack-audio-connection-kit (pipewire-jack-audio-connection-kit)

This is very annoying because qjackctl is important for routing JACK applications to various sound sources.

Version-Release number of selected component (if applicable):

qjackctl-0.9.0-2
pipewire-0.3.20

How reproducible:

Always

Steps to Reproduce:
1. Try starting qjackctl.


Actual results:

qjackctl does not start

Expected results:

qjackctl starts successfully

Additional info:

This is in journalctl:

Feb 04 13:31:39 localhost.localdomain qjackctl.desktop[2293]: qjackctl: symbol lookup error: qjackctl: undefined symbol: jack_session_commands_free
Feb 04 13:31:39 localhost.localdomain systemd[1465]: app-gnome-qjackctl-2293.scope: Succeeded.
Feb 04 13:42:19 localhost.localdomain qjackctl.desktop[3479]: qjackctl: symbol lookup error: qjackctl: undefined symbol: jack_session_commands_free
Feb 04 13:42:19 localhost.localdomain systemd[1465]: app-gnome-qjackctl-3479.scope: Succeeded.

Comment 1 Lukas Ruzicka 2021-02-04 13:41:06 UTC
Switching to the old JACK implementation, the jack-audio-connection-kit solves the problem, so this might be a PipeWire problem also. Adding
@wtaymans@redhat.com.

Comment 2 Lukas Ruzicka 2021-02-04 13:43:42 UTC
No similar problems are found on Fedora 33.

Comment 3 Wim Taymans 2021-02-04 14:24:17 UTC
PipeWire needs to implement those methods.

Comment 4 Ankur Sinha (FranciscoD) 2021-02-04 14:37:18 UTC
Thanks Lukas and Wim. Is there a bug for pipewire that this can depend on, or should we reassign this to pipewire?

Comment 6 Fedora Update System 2021-02-04 16:55:01 UTC
FEDORA-2021-94b5ec2fd1 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2021-02-04 17:09:38 UTC
FEDORA-2021-d6d23603c6 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d6d23603c6

Comment 8 Fedora Update System 2021-02-05 01:27:34 UTC
FEDORA-2021-d6d23603c6 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d6d23603c6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d6d23603c6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Lukas Ruzicka 2021-02-05 11:00:19 UTC
I can confirm that the issue is solved in 0.3.21, thank you.

Comment 10 Fedora Update System 2021-02-05 16:31:39 UTC
FEDORA-2021-854ef86c22 has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-02-06 01:18:05 UTC
FEDORA-2021-d6d23603c6 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.