Bug 192599 - kernel-debuginfo.i686 0:2.6.16-1.2111_FC5 missing "ieee1394-ioctl.h"
Summary: kernel-debuginfo.i686 0:2.6.16-1.2111_FC5 missing "ieee1394-ioctl.h"
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-21 17:40 UTC by Matt Ghali
Modified: 2015-01-04 22:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 19:26:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Ghali 2006-05-21 17:40:25 UTC
Description of problem:
/usr/src/debug/kernel-2.6.16/linux-2.6.16.i686/drivers/ieee1394/video1394.h contains, on line 24:

#include "ieee1394-ioctl.h"

Yet there is no such file "ieee1394-ioctl.h" in the same directory.

Version-Release number of selected component (if applicable):
no revision control tag in "video1394.h".

How reproducible:
Very

Steps to Reproduce:
1. include /usr/src/debug/kernel-2.6.16/linux-2.6.16.i686/drivers/ieee1394/video1394.h
2. build using gcc
3. cry
  
Actual results:
In file included from unlisten_1394.c:12:
/usr/src/debug/kernel-2.6.16/linux-2.6.16.i686/drivers/ieee1394/video1394.h:24:28: error: 
ieee1394-ioctl.h: No such file or directory

Expected results:
no error

Additional info:
Trying to build camwire: http://kauri.auck.irl.cri.nz/~johanns/camwire/

Comment 1 Matt Ghali 2006-05-21 17:45:32 UTC
My mistake- the rpm which seems to be missing the file is "kernel-debuginfo.i686 0:2.6.16-1.2111_FC5", 
not "kernel-devel.i686 2.6.16-1.2111_FC5". Sorry!

Comment 2 Dave Jones 2006-05-22 19:26:39 UTC
debuginfo isn't meant to be compiled. It's there as a reference for tools like gdb.


Comment 3 Matt Ghali 2006-05-22 19:47:40 UTC
video1394.h includes a missing file, which makes it broken, regardless of usage.


Note You need to log in before you can comment on or make changes to this bug.