Bug 192601 - Transport map for cyrus has wrong hard-coded path
Transport map for cyrus has wrong hard-coded path
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postfix (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 15:52 EDT by Felipe Alfaro Solana
Modified: 2008-07-24 15:58 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0730
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix hard-coded path to cyrus-imapd/deliver for x86_64 (970 bytes, patch)
2006-05-21 15:52 EDT, Felipe Alfaro Solana
no flags Details | Diff

  None (edit)
Description Felipe Alfaro Solana 2006-05-21 15:52:28 EDT
Description of problem:
/etc/postfix/master.cf file of postfix-2.1.5-4.2.RHEL4 has hard-coded paths to
cyrus-imapd LMTP deliver agent, actually /usr/lib/cyrus-imapd/deliver. This
causes problems on x86_64 systems since the cyrus-imapd LMTP deliver agent path
is /usr/lib64/cyrus-imapd/deliver.

I have attached a small patch against master.cf file of
postfix-2.1.5-4.2.RHEL4.x86_64 to fix this issue.

Version-Release number of selected component (if applicable):
postfix-2.1.5-4.2.RHEL4.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Enable mailbox_transport = cyrus in /etc/postfix/main.cf
2. service postfix restart
3. mail root
4. The mail will bounce since postfix will try invoking
/usr/lib/cyrus-imapd/deliver instead of /usr/lib64/cyrus-imapd/deliver
  
Actual results:


Expected results:


Additional info:
Comment 1 Felipe Alfaro Solana 2006-05-21 15:52:28 EDT
Created attachment 129783 [details]
Fix hard-coded path to cyrus-imapd/deliver for x86_64
Comment 3 RHEL Product and Program Management 2007-11-28 23:25:39 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:58:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0730.html

Note You need to log in before you can comment on or make changes to this bug.