This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 192627 - xterm doesn't show all chars (fonts related)
xterm doesn't show all chars (fonts related)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 19:40 EDT by Jiri Slaby
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 213-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-03 08:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Slaby 2006-05-21 19:40:56 EDT
Description of problem:
xterm doesn't show unicode chars properly. It shows blank chars instead. I also
tried to update from rawhide, but with no effect.
LANG=cs_CZ.UTF-8

Version-Release number of selected component (if applicable):
xterm-212-1.FC5
xorg-x11-fonts-misc-7.0-3
xorg-x11-xfs-1.0.2-1
xorg-x11-server-Xorg-1.0.99.903-1

How reproducible:
always

Steps to Reproduce:
1. ls -l and there are blank chars in names of months of file/dir creation time.
  
Actual results:
-rw-r--r--  1 xslaby xslaby   7786586  íj 30  2000 v001.wav

Expected results:
-rw-r--r--  1 xslaby xslaby   7786586 říj 30  2000 v001.wav

Additional info:
I tried -u8 with no effect. It seems it chooses bad font. When I try:
xterm -font -misc-fixed-medium-r-semicondensed-*-13-*-*-*-*-*-iso10646-*
it seems to be fine.
I have this problem on both desktop and notebook with FC5.
My .Xresources contains only this:
xterm*background: Black
xterm*foreground: White
XTerm*scrollBar: false
Comment 1 Jason Vas Dias 2006-05-22 12:17:05 EDT
Hi -
Does it work when you specify:
  # xterm -en utf-8  
Or if instead of running 'xterm' you run 
  # uxterm
?

Xterm by default, unless you've specified the default font resource or 
command line argument, will load the font associated with the alias
'fixed' (at least it does on my system) which on my system is specified
in /usr/share/X11/fonts/misc/fonts.alias as:
fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
ie. an iso8859-1 encoding.

Invoking xterm with the '-en utf-8' argument or as 'uxterm' should make it 
use the utf-8 encoding by default.

A set of Xresources to specify UTF-8 encoded fonts as the default is shipped
in the file /usr/share/X11/app-defaults/UXTerm - you might consider sourcing
this file in your ~/.Xresources with '#include "UXterm"' or putting 
'#include "UXTerm"' in your system default /usr/share/X11/app-defaults/XTerm
file if all your users expect the UTF-8 encoding to be the default.
Comment 2 Jiri Slaby 2006-05-22 19:57:58 EDT
Hi.
xterm -en utf-8 does not solve the problem.
xterm -class UXTerm (it's called by uxterm that way) or including UXTerm do, but
it's only cloberring the bug or anything else.

fixed is aliased to iso-8859-1 font here too
and
! Here is a simple description.  A technically precise one would be very long.
! When xterm starts up, it uses the
!
!       *VT100.font
!
! resource, and if it is told to switch to wide-character (UTF-8) mode, it
! checks if the given font is "wide", and if not looks for the
!
!       *VT100.utf8Fonts.font
!
! to obtain a wide font.  A "wide" font has more than 256 glyphs.  Typical
! wide fonts have 10,000 glyphs.  If the original "*VT100.font" is not wide,
! and xterm can load the *VT100.utf8Fonts.font, it will use that.
and
iso8859-1 font (fixed, the default) contains only 256 glyphs, so it's not wide,
why doesn't xterm choose utf8font, which is set appropriate, when it's told to
be in wide char. mode?
Comment 3 Jason Vas Dias 2006-05-31 18:26:47 EDT
This bug is now fixed in upstream version 213 - from the xterm ChangeLog:
" add utf8Latin1 resource to make optional the feature from patch #209 which    
  allowed ISO-8859-1 fonts to be used in cases where a wide font was given. This 
  would only work for the special case where the user normally used Latin-1 and 
  wanted some wide characters (report by Rostislav Krasny). 
"
Whatever that was about, it also fixed your issue - a wide font is now used by
default in UTF-8 locales - fixed in xterm-213-1.FC5, being release to 
updates/testing today.
Comment 4 Fedora Update System 2006-05-31 19:19:15 EDT
xterm-213-1.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2006-05-31 19:19:41 EDT
xterm-213-1.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Jiri Slaby 2006-06-03 08:55:14 EDT
Still no xterm-213-1 in FC5 update repo, but after updating xterm from devel
tree, it's OK. Thanks.

Note You need to log in before you can comment on or make changes to this bug.