Bug 192645 - LTC21163-72716: DASD awareness for multipath-tools
LTC21163-72716: DASD awareness for multipath-tools
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.5
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Ben Marzinski
: FutureFeature
: 180629 (view as bug list)
Depends On:
Blocks: 176344 196038 200231 202207
  Show dependency treegraph
 
Reported: 2006-05-22 10:24 EDT by Daniel Riek
Modified: 2010-01-11 21:25 EST (History)
17 users (show)

See Also:
Fixed In Version: RHEA-2007-0256
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2006-05-22 10:24:34 EDT
As discussed in the IBM Architecture meeting on May 22nd, this replaces a more
specific request in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180629


+++ This bug was initially created as a clone of Bug #184783 +++

Escalated to Bugzilla from IssueTracker

-- Additional comment from tao@redhat.com on 2006-03-10 03:10 EST --
From User-Agent: XML-RPC


LTC Owner is: buendgen@de.ibm.com
LTC Originator is: emmons@us.ibm.com


REQUIREMENT
DASD awareness for multipath-tools

CATEGORY
Networks/devices/ storage

REQUEST TYPE
Package - Feature from IBM

DESCRIPTION
The multipath-tools are a set of user space tools that analyze all block
devices in a system and automatically coalesce paths to identical devices by
creating logical device mapper devices. The purpose of this line item is to
extend these multipath-tools to support DASD disks.

The multipath tools set consists of multiple tools. The necessary extensions to
specific tools	are:
Partner requirements: 71421, 71232, 71234, 71237,71546, 62140,42858

ADDITIONAL DESCRIPTION
+multipath:
The purpose of the program 'multipath' is to scan the block devices known to
the system and to create device mapper devices on those block devices that it
recognizes as identical. To do so it calls an external plugin ('callout') that
is supposed to return a unique identifier for each physical device (e.g. a
serial number). There is a default plugin that supports only SCSI devices, but
further plugins can be specified in the device type entries of the multipath
configuration file (/etc/multipath.conf). 
Currently these device type entries can only be specified for SCSI devices.
This line item will extend this functionality to arbitrary devices.  
+kpartx:
The tool multipath maps each complete physical device to one logical device.
The tool kpartx creates additional logical devices for the partitions on the
physical device. 
This line item will add DASD partition support to kpartx. 


JUSTIFICATION
A first product to benefit from this item will be the new version of GDPS/PPRC
Multiplatform Resiliency Offering which for the first time allows building a
D/R solution for computing environments comprising z/OS and Linux images
running in zSeries LPARs (e.g. large application servers). This is a very
attractive offering to zSeries customers to procet their business.

TECH BENEFITS
The multipath-tools are an accepted set of tools for setting up device-mapper
multipath targets from user space. Using these tools for new multipath based
solutions will simplify the implementation and enhance community and
distributor acceptance.

LDP PRIORITY
1

LDP ID#
72716

SPONSOR
zSeries

CONF
Y

KERNELS
2.6

BITNESS
 ,31/32 compatibility mode,64 bit native

COMPLETION DATE
12/31/2005

TARGETZ
Y

CONTACT NAME
Reinhard Buendgen

CONTACT EMAIL
buendgen@de.ibm.com

CONTACT PHONE
+49 7031 16 1130
This event sent from IssueTracker by llu 
 issue 80055

-- Additional comment from tao@redhat.com on 2006-03-13 12:50 EST --
From User-Agent: XML-RPC

---- Additional Comments From hannsj_uhl@de.ibm.com  2006-03-13 12:52 EDT
-------
Hello Red Hat,
fyi ... this support is upstream in multipath-tools-0.4.7 ... 
... see http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=Home 
Thanks for your support. 


This event sent from IssueTracker by Glen Johnson 
 issue 80055

-- Additional comment from tao@redhat.com on 2006-03-14 22:48 EST --
From User-Agent: XML-RPC

Issue Registered (Severity: 1)
This event sent from IssueTracker by llu 
 issue 80055

-- Additional comment from tao@redhat.com on 2006-03-14 22:48 EST --
From User-Agent: XML-RPC



Status set to: Waiting on Tech

This event sent from IssueTracker by llu 
 issue 80055

-- Additional comment from tao@redhat.com on 2006-03-14 22:48 EST --
From User-Agent: XML-RPC

---- Additional Comments From hannsj_uhl@de.ibm.com  2006-03-06 13:01 EDT
-------
Hello Red Hat,
fyi ... the following three RHEL5 requirements are going together:
- LTC bug 18425 - RIT80038-62140: (big) xDR system Initialization for 
  LPAR Clients
- LTC bug 18435 - RIT80050- 71546: dm-mp support for xDR/GDPS
- LTC bug 18439 - RIT80055- 72716: DASD awareness for multipath-tools
  (this bugzilla)
Thanks for your support. 


This event sent from IssueTracker by llu 
 issue 80055

-- Additional comment from tao@redhat.com on 2006-03-14 22:48 EST --
From User-Agent: XML-RPC

---- Additional Comments From hannsj_uhl@de.ibm.com  2006-03-13 12:52 EDT
-------
Hello Red Hat,
fyi ... this support is upstream in multipath-tools-0.4.7 ... 
... see http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=Home 
Thanks for your support. 

This event has been forwarded to Red Hat engineers

This event sent from IssueTracker by llu 
 issue 80055
Comment 1 Daniel Riek 2006-05-22 10:29:53 EDT
*** Bug 180629 has been marked as a duplicate of this bug. ***
Comment 2 Hanns-Joachim Uhl 2006-06-29 07:41:19 EDT
Hello Red Hat,
please change the LTC bug number in 'Summary' ..
... it has to read 'LTC21163- ..' for this RHEL4.5 feature request .
(fyi .. 'LTC18439- ..' is for RHEL5 .. see bug 184783 ...)
Thanks for your help.
Comment 8 John Jarvis 2006-08-11 13:00:58 EDT
Adding to the RHEL 4.5 BTM feature tracker
Comment 12 Jay Turner 2006-08-25 10:52:40 EDT
QE ack for 4.5.
Comment 13 Kiersten (Kerri) Anderson 2006-09-06 16:24:29 EDT
Devel ACK for 4.5 based on the code already being upstream and available.
Comment 14 John Jarvis 2006-09-06 16:36:32 EDT
This feature is In Plan for RHEL 4.5 based on the code already being upstream
and available.
Comment 20 Red Hat Bugzilla 2007-05-01 13:37:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0256.html

Note You need to log in before you can comment on or make changes to this bug.