Bug 19265 - kickstart in RH6.2 fails with --onpart option used
kickstart in RH6.2 fails with --onpart option used
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 11:58 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 11:58:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-10-17 11:58:49 EDT
If the --onpart option is used with kickstart on the partition command,
anaconda dies in todo.py at line 395 at the line:

        self.mounts[location] = (device, fsystem, reformat)

in the addMount method because mounts is not an attribute of self.
Comment 1 Red Hat Bugzilla 2000-10-17 18:31:51 EDT
the --onpart option is known to have issues in 6.2 ... Red Hat Linux 7 has much
more robust behavior for this command ... please let me know if you are still
having this problem using 7 ... thanks for your report!

additionally, if this continues to be a problem for you please feel free to
attach the kickstart file, we'd be glad to try to verify any problems you have
... :)

Note You need to log in before you can comment on or make changes to this bug.