Bug 19266 - glibc-2.1.94: /usr/include/netinet/tcp.h
Summary: glibc-2.1.94: /usr/include/netinet/tcp.h
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 16:00 UTC by Alex Efros
Modified: 2016-11-24 15:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 13:13:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Efros 2000-10-17 16:00:54 UTC
CPAN module GTop.pm includes /usr/include/netinet/tcp.h and failed while
compiling.
This problem not found in old glibc version - 2.1.92

Comment 1 Jakub Jelinek 2000-10-17 21:24:28 UTC
If it is because of undefined uintXX_t types, then
2000-10-14  Ulrich Drepper  <drepper@redhat.com>

        * sysdeps/gnu/netinet/tcp.h: Use u_intXX_t types instead of
        uintXX_t since this is what <sys/types.h> defines and we include
        this header.  Reported by Bernhard Rosenkraenzer <bero@redhat.de>.

should fix it (it will appear in the next errata), otherwise
please give some details on what errors do you see.

Comment 2 Alex Efros 2000-10-18 13:13:01 UTC
Yes it is. This is uint => u_int bug.

Comment 3 Jakub Jelinek 2000-10-20 12:29:34 UTC
Ok, then it should be fixed in glibc-2.1.95-1 and above, which I hope will
make it into rawhide soon (just the rawhide making machinery has to be fixed
so that it does not override newer glibcs with the preview/ rpms).


Note You need to log in before you can comment on or make changes to this bug.