Bug 1927669 - e1000e NIC do not respect link state set in virt-manager
Summary: e1000e NIC do not respect link state set in virt-manager
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 33
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2021-02-11 10:08 UTC by Sampson Fung
Modified: 2021-02-14 22:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-02-14 22:15:30 UTC
Type: Bug

Attachments (Terms of Use)

Description Sampson Fung 2021-02-11 10:08:37 UTC
Description of problem:
Even when Link State is setup to disabled in virt-manager, guest network link is still up when using the e1000e driver, both Fedora and Windows guests tested with same result.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Create new Guest (Fedora and/or Windows) using e1000e NIC, with link state enabled, connecting to NAT network
2.  while guest is running, set link state to disabled
3.  shutdown guest and start guest

Actual results:
Guest got IP address via DHCP and access to Internet is OK.

Expected results:
Guest NIC link should be down, and no IP address should be assigned.

Additional info:
When the client is up and running, set link down and guest network is down immediately.

But on shutdown / restart, guest network link is up although virt-manager NIC link setting is still down.

Changing to virtio NIC driver, and link state is working correctly.

Tested with Windows and Fedora guest, both give same result.

Discussion thread at Ask: https://ask.fedoraproject.org/t/virt-manager-nic-link-state-set-to-down-but-guest-network-still-connected/12253?u=sampsonf

Comment 1 Cole Robinson 2021-02-14 22:15:30 UTC
Thanks for the report. This has been reported before and t's a known qemu issue that has been filed upstream. See the discussion here: https://github.com/virt-manager/virt-manager/issues/66

The upstream qemu bug is here. But it is still not fixed AFAIK: https://bugs.launchpad.net/qemu/+bug/1857226

Note You need to log in before you can comment on or make changes to this bug.