This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 19277 - new php.ini patch for 4.03pl1 with enhancement
new php.ini patch for 4.03pl1 with enhancement
Status: CLOSED DUPLICATE of bug 19276
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 13:35 EDT by chrismcc
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 13:35:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chrismcc 2000-10-17 13:35:44 EDT
php-4.0.1pl2-redhat.patch is a patch to php version 4.01pl1.  I breaks
slightly with the new 4.03pl1. It also removes th commented out options to
include other extensions at run time.  (like the mysql, imap, etc
extensions).  Leaving these in would allow third parties (like sysadmins)
to release a php-MODULE-4...rpm, like php-oracle-4.0.3pl1.i386.rpm. Without
recompiling the php base binary or using any fancy scripting to add it to
the php.ini and install time.  Also added is a line for a third party
module, oas, which is an ad serving php module.


-------------patch--------------

--- php-4.0.3pl1/php.ini-dist.redhat	Tue Oct 17 10:09:45 2000
+++ php-4.0.3pl1/php.ini-dist	Tue Oct 17 10:19:43 2000
@@ -227,10 +227,10 @@
 ;;;;;;;;;;;;;;;;;;;;;;;;;
 ; Paths and Directories ;
 ;;;;;;;;;;;;;;;;;;;;;;;;;
-include_path
=                   ; UNIX: "/path1:/path2"  Windows: "\path1;\path2"
+include_path
=       .:/usr/share/php            ; UNIX: "/path1:/path2"  Windows:
"\path1;\path2"
 doc_root
	=					; the root of the php pages, used only if nonempty
 user_dir
	=					; the directory under which php opens the script using /~username, used only if
nonempty
-extension_dir
=
./
			; directory in which the loadable extensions (modules) reside
+extension_dir
=
/usr/lib/php4
			; directory in which the loadable extensions (modules) reside
 enable_dl
	= On
			; Whether or not to enable the dl() function.

								; The dl() function does NOT properly work in multithreaded

								; servers, such as IIS or Zeus, and is automatically disabled
@@ -258,35 +258,38 @@
 ; needs to go here.  Specify the location of the extension with the
extension_dir directive above.


-;Windows Extensions
-;Note that MySQL and ODBC support is now built in, so no dll is needed for it.
+;UNIX/Linux Extensions
 ;
-;extension=php_cpdf.dll
-;extension=php_cybercash.dll
-;extension=php_db.dll
-;extension=php_dbase.dll
-;extension=php_domxml.dll
-;extension=php_dotnet.dll
-;extension=php_exif.dll
-;extension=php_fdf.dll
-;extension=php_gd.dll
-;extension=php_gettext.dll
-;extension=php_ifx.dll
-;extension=php_imap.dll
-;extension=php_interbase.dll
-;extension=php_java.dll
-;extension=php_ldap.dll
-;extension=php_mhash.dll
-;extension=php_mssql65.dll
-;extension=php_mssql70.dll
-;extension=php_oci8.dll
-;extension=php_oracle.dll
-;extension=php_pdf.dll
-;extension=php_pgsql.dll
-;extension=php_sablot.dll
-;extension=php_swf.dll
-;extension=php_sybase_ct.dll
-;extension=php_zlib.dll
+;extension=cpdf.so
+;extension=cybercash.so
+;extension=db.so
+;extension=dbase.so
+;extension=domxml.so
+;extension=dotnet.so
+;extension=exif.so
+;extension=fdf.so
+;extension=gd.so
+;extension=gettext.so
+;extension=ifx.so
+;extension=imap.so
+;extension=interbase.so
+;extension=java.so
+;extension=ldap.so
+;extension=mhash.so
+;extension=mssql65.so
+;extension=mssql70.so
+;extension=oci8.so
+;extension=oracle.so
+;extension=pdf.so
+;extension=pgsql.so
+;extension=sablot.so
+;extension=swf.so
+;extension=sybase_ct.so
+;extension=zlib.so
+;extension=oas.so
+;extension=pgsql.so
+;extension=mysql.so
+


 ;;;;;;;;;;;;;;;;;;;
Comment 1 chrismcc 2000-10-17 13:38:31 EDT
Oops,,,

*** This bug has been marked as a duplicate of 19276 ***

Note You need to log in before you can comment on or make changes to this bug.