Bug 19278 - thumbpdf fails
thumbpdf fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 13:36 EDT by Lindsay Todd
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 15:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lindsay Todd 2000-10-17 13:36:17 EDT
The thumbpdf file, used to insert thumbnails into pdflatex documents, has
two problems.

First, a perl problem at line 23.  I'm not a perl expert, so there is
probably a better fix than this patch,
but it works for me:

*** /usr/bin/thumbpdf.OLD	Mon Oct  2 15:11:08 2000
--- /usr/bin/thumbpdf	Mon Oct  2 15:11:29 2000
***************
*** 20,26 ****
  # for installation purposes.
  #
  my $file        = "thumbpdf.pl";
! my $program     = uc($file =~ /^(\w+)/, $1);
  my $version     = "1.11";
  my $date        = "2000/01/19";
  my $author      = "Heiko Oberdiek";
--- 20,26 ----
  # for installation purposes.
  #
  my $file        = "thumbpdf.pl";
! my $program     = uc($file);
  my $version     = "1.11";
  my $date        = "2000/01/19";
  my $author      = "Heiko Oberdiek";


Second, pdftex was linked to the wrong version of PNG.  I see that others
have previously reported this problem.
Comment 1 Jeff Johnson 2000-12-27 15:37:10 EST
Fixed in tetex-1.0.7-9.

Note You need to log in before you can comment on or make changes to this bug.