Bug 192786 - F-spot won't start
F-spot won't start
Status: CLOSED DUPLICATE of bug 192595
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 19:15 EDT by Joshua Wulf
Modified: 2014-10-19 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 13:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2006-05-22 19:15:40 EDT
Description of problem:
Starting f-spot crashes with an error

Version-Release number of selected component (if applicable):
f-spot-0.1.11-1

How reproducible:
100%

Steps to Reproduce:
1. start f-spot either at command prompt or from gnome-menu
2.
3.
  
Actual results:
crashes with following error:
[jwulf@localhost ~]$ f-spot
Starting new FSpot server
System.NullReferenceException: Object reference not set to an instance of an object
in <0x00044> Gtk.Widget:set_GdkWindow (Gdk.Window value)
in <0x00058> FSpot.GroupSelector:OnRealized ()
in <0x0007c> Gtk.Widget:realized_cb (IntPtr widget)
in (wrapper native-to-managed) Gtk.Widget:realized_cb (intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Box:gtk_box_pack_start
(intptr,intptr,bool,bool,uint)
in <0x00084> Gtk.Box:PackStart (Gtk.Widget child, Boolean expand, Boolean fill,
UInt32 padding)
in <0x00ac8> MainWindow:.ctor (.Db db)
in <0x00048> FSpot.Core:get_MainWindow ()
in <0x00018> FSpot.Core:Organize ()
in <0x006ac> FSpot.Driver:Main (System.String[] args)

(f-spot:5956): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height
>= -1' failed

(f-spot:5956): Gdk-CRITICAL **: gdk_window_invalidate_maybe_recurse: assertion
`window != NULL' failed

(f-spot:5956): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height
>= -1' failed

(f-spot:5956): Gdk-CRITICAL **: gdk_window_invalidate_maybe_recurse: assertion
`window != NULL' failed

Unhandled Exception: System.NullReferenceException: Object reference not set to
an instance of an object
in <0x0011c> FSpot.GroupSelector:set_Offset (Int32 value)
in <0x006d4> FSpot.GroupSelector:OnSizeAllocated (Rectangle alloc)
in <0x000c4> Gtk.Widget:sizeallocated_cb (IntPtr widget, Gdk.Rectangle allocation)
in (wrapper native-to-managed) Gtk.Widget:sizeallocated_cb (intptr,Gdk.Rectangle&)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Dialog:gtk_dialog_run (intptr)
in <0x00038> Gtk.Dialog:Run ()
in <0x00738> FSpot.Driver:Main (System.String[] args)


Expected results:
should start

Additional info:
Comment 1 Joshua Wulf 2006-05-23 01:47:28 EDT
Is this a duplicate of 192595? It looks like the same thing.
Comment 2 Bart Vanbrabant 2006-06-06 14:16:00 EDT
This is the same as #192595, posted a fix there.
Comment 3 Matthias Clasen 2006-07-25 13:19:58 EDT

*** This bug has been marked as a duplicate of 192595 ***

Note You need to log in before you can comment on or make changes to this bug.