Bug 192787 - vim-common: unowned directories
vim-common: unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
: 193147 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 19:54 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 06:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2006-05-22 19:54:54 EDT
Description of problem:
The package vim-common leaves directories when removed.

Version-Release number of selected component (if applicable):
vim-common-7.0.016-1.i386.rpm

How reproducible:
Always.

Steps to Reproduce:
System without vim-common installed 
1. rpm -ivh vim-common-7.0.016-1.i386.rpm
2. rpm -e vim-common
3. find /usr/share/vim 
  
Actual results:
The following directories are left in the disk:
/usr/share/vim
/usr/share/vim/vim70
/usr/share/vim/vim70/lang
/usr/share/vim/vim70/lang/zh_CN
/usr/share/vim/vim70/lang/fr
...

Expected results:
No unowned directories in the filesystem.

Additional info:
I believe the specfile lines
   %lang(af) /usr/share/vim/%{vimdir}/lang/af/*
   %lang(ca) /usr/share/vim/%{vimdir}/lang/ca/*
   %lang(cs) /usr/share/vim/%{vimdir}/lang/cs/*
   ...
shouldn't end with '*' or else the lang directories aren't
owned by the package vim-common (only the files inside it).
Comment 1 Jose Pedro Oliveira 2006-05-29 10:31:59 EDT
Pinging as I don't know if this bug reported has been seen.
(When this ticket was submitted bugzilla had been down for more than a day and
for several hours more it didn't sent emails).
Comment 2 Karsten Hopp 2006-05-29 11:24:19 EDT
*** Bug 193147 has been marked as a duplicate of this bug. ***
Comment 3 Robert Scheck 2006-05-29 11:26:53 EDT
Guessing, it was seen now. But not fixed, yet ;-)
Comment 4 Karsten Hopp 2006-05-30 06:37:32 EDT
but now... vim-7.0.017-1

Note You need to log in before you can comment on or make changes to this bug.