Bug 1927972 - Add-on install popover (and possibly others) cut off (maybe only on KDE?)
Summary: Add-on install popover (and possibly others) cut off (maybe only on KDE?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 34
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks: F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-02-12 01:06 UTC by Adam Williamson
Modified: 2021-03-06 05:35 UTC (History)
13 users (show)

Fixed In Version: firefox-86.0-7.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-06 05:35:56 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of the bug (154.62 KB, image/png)
2021-02-12 01:07 UTC, Adam Williamson
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 1685263 0 P2 UNCONFIRMED [wayland] Firefox flickers in KDE Plasma 2021-02-17 17:28:39 UTC

Description Adam Williamson 2021-02-12 01:06:30 UTC
In today's openQA tests of Fedora 34, the browser test failed on KDE because the popover that appears when you try to install an add-on is kinda chopped off:

https://openqa.fedoraproject.org/tests/775096#step/desktop_browser/15

the right and bottom sides aren't fully displayed. This may be KDE-specific and to do with recent changes to do with Wayland, but I'm not sure. I can't tell if it's happening on GNOME too because a different bug prevents the test even launching Firefox there.

Comment 1 Adam Williamson 2021-02-12 01:07:15 UTC
Created attachment 1756497 [details]
screenshot of the bug

Attaching a screenshot of the bug for the record (the openQA test assets will get garbage collected in a couple of weeks).

Comment 2 Neal Gompa 2021-02-12 01:24:44 UTC
It was mentioned on the KDE mailing list that installing libglvnd-gles helped resolve this: https://lists.fedoraproject.org/archives/list/kde@lists.fedoraproject.org/thread/P7FFQFGA3BH6GL6HB3AASXYZI4PJSYEB/#XTU73LTBQTHQL6WCXQRLO3J6PVM6DPMB

Rex suggested that a fix for this would be to add "Recommends: libglvnd-gles%{?_isa}" to Firefox, though I would probably say it should be a Requires with WebRender using GLES.

Comment 3 Martin Stransky 2021-02-12 11:27:09 UTC
I have installed on my system:

libglvnd-1.3.2-2.fc33.x86_64
libglvnd-egl-1.3.2-2.fc33.x86_64
libglvnd-glx-1.3.2-2.fc33.x86_64
libglvnd-gles-1.3.2-2.fc33.x86_64
libglvnd-opengl-1.3.2-2.fc33.x86_64
libglvnd-core-devel-1.3.2-2.fc33.x86_64
libglvnd-devel-1.3.2-2.fc33.x86_64

But this is really system level dependency which needs to be installed by MESA or so, not by Firefox.
Anyway, Adam, Is there a way how to add the package to OpenQA to verify it helps?

Comment 4 J. Penala 2021-02-12 13:54:37 UTC
Regarding 'libglvnd-gles', it's part of the default Workstation install. If you run "dnf groupinstall 'Fedora Workstation'" on the spins, it will pull in 'libglvnd-gles'.

Comment 5 Adam Williamson 2021-02-12 17:50:55 UTC
Yeah, I can test if the openQA test works if we install the package first. Will get to it in a bit.

Comment 6 Adam Williamson 2021-02-12 20:56:29 UTC
That, uh, seems to make it worse?

First try after adding a bit to the test to install libglvnd-gles and reboot failed on this:
https://openqa.stg.fedoraproject.org/tests/1035400#step/desktop_browser/20

Second try even weirder:
https://openqa.stg.fedoraproject.org/tests/1035404#step/desktop_browser/19

Comment 7 Martin Stransky 2021-02-13 10:49:01 UTC
(In reply to Adam Williamson from comment #6)
> That, uh, seems to make it worse?
> 
> First try after adding a bit to the test to install libglvnd-gles and reboot
> failed on this:
> https://openqa.stg.fedoraproject.org/tests/1035400#step/desktop_browser/20
> 
> Second try even weirder:
> https://openqa.stg.fedoraproject.org/tests/1035404#step/desktop_browser/19

Looks like WebRender is disabled and SW rendering is used. Can you show/attach about:support page from the OpenQA session?

Comment 8 Neal Gompa 2021-02-14 02:08:35 UTC
I was able to reproduce this in a VMware VM, and it was immediately fixed after installing libglvnd-gles. Maybe it needs that to switch over to WebRender?

Comment 9 Martin Stransky 2021-02-15 09:27:54 UTC
(In reply to Neal Gompa from comment #8)
> I was able to reproduce this in a VMware VM, and it was immediately fixed
> after installing libglvnd-gles. Maybe it needs that to switch over to
> WebRender?

It's possible that Firefox fall back to SW (which is broken on KDE) when libglvnd-gles is missing.

Comment 10 Adam Williamson 2021-02-17 17:29:43 UTC
I'll try and get about:support page when I can, I have to teach openQA to open it and screenshot it, sorry, got distracted.
Note the openQA VMs are not configured with 3D acceleration support, I don't think. We use the virtio virtual adapter but I don't think os-autoinst sets it up for 3D.

Comment 11 Neal Gompa 2021-02-17 23:18:18 UTC
(In reply to Adam Williamson from comment #10)
> I'll try and get about:support page when I can, I have to teach openQA to
> open it and screenshot it, sorry, got distracted.
> Note the openQA VMs are not configured with 3D acceleration support, I don't
> think. We use the virtio virtual adapter but I don't think os-autoinst sets
> it up for 3D.

LLVMpipe is better than Firefox's basic rendering mode. Because of bug 1921523, I've been using VMware with 3D acceleration disabled too. It still massively improves things.

Comment 12 Neal Gompa 2021-02-21 19:26:07 UTC
I've submitted a PR for this: https://src.fedoraproject.org/rpms/firefox/pull-request/32

Comment 13 Martin Stransky 2021-02-22 09:39:43 UTC
Until KWin/Wayland backend get fixed I'm going switch back to X11 on KDE to avoid such issues.

Comment 14 Adam Williamson 2021-02-22 16:45:03 UTC
Neal: but as I wrote, installing libglvnd-gles didn't appear to help things in openQA at all.

Comment 15 Neal Gompa 2021-02-24 03:43:55 UTC
(In reply to Adam Williamson from comment #14)
> Neal: but as I wrote, installing libglvnd-gles didn't appear to help things
> in openQA at all.

It pretty much fixed it for me everywhere (my KVM VMs, my VMware VMs, my laptops, and my desktop). Without that, I got nothing. I don't even know where to begin for figuring out what's wrong here.

Comment 16 Martin Stransky 2021-02-24 06:46:29 UTC
Don't worry, I'll take it. Should be fixed in next FF release - 86.0 which should come out this week.

Comment 17 JayJayJazz 2021-02-24 11:20:37 UTC
(In reply to Martin Stransky from comment #16)
> Don't worry, I'll take it. Should be fixed in next FF release - 86.0 which
> should come out this week.

Firefox 86.0 is already available:
https://bugzilla.redhat.com/show_bug.cgi?id=1931823

Comment 18 Adam Williamson 2021-03-03 01:39:46 UTC
I'm proposing this as a Beta FE, I think it would be wise to pull 86.0 (and the nss it requires) into Beta to make sure this isn't an issue. Will mark both updates as fixing this bug.

Comment 19 Fedora Update System 2021-03-03 01:40:30 UTC
FEDORA-2021-688bf3e82e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-688bf3e82e

Comment 20 Fedora Update System 2021-03-03 01:41:13 UTC
FEDORA-2021-bdc10e21fc has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bdc10e21fc

Comment 21 Fedora Update System 2021-03-03 15:46:33 UTC
FEDORA-2021-688bf3e82e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-688bf3e82e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-688bf3e82e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2021-03-04 16:57:24 UTC
FEDORA-2021-578907b183 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-578907b183`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-578907b183

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2021-03-06 05:35:51 UTC
FEDORA-2021-bdc10e21fc has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Fedora Update System 2021-03-06 05:35:56 UTC
FEDORA-2021-578907b183 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.