Bug 192812 - [ml_IN]GPOS issues in new Malayalam font
[ml_IN]GPOS issues in new Malayalam font
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 07:17 EDT by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 18:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verified Image (111.18 KB, image/png)
2007-04-27 07:49 EDT, A S Alam
no flags Details
Updated screenshot (38.29 KB, image/png)
2007-05-18 07:39 EDT, A S Alam
no flags Details
Correct glyph for gedit/kedit (128.69 KB, image/png)
2007-05-18 08:08 EDT, Ani Peter
no flags Details
screenshot for correct and wrong combinations (145.34 KB, image/png)
2008-01-24 01:03 EST, Ani Peter
no flags Details
patch for Lohit-Bengali.sfd (654 bytes, patch)
2008-01-24 02:50 EST, Rahul Bhalerao
no flags Details | Diff
patch for Lohit-Malayalam.sfd (654 bytes, patch)
2008-01-24 02:50 EST, Rahul Bhalerao
no flags Details | Diff
fixed ttf file (53.18 KB, application/x-font-ttf)
2008-01-24 02:52 EST, Rahul Bhalerao
no flags Details

  None (edit)
Description Ani Peter 2006-05-23 07:17:07 EDT
Description of problem:
The below shown combinations must be displayed according to the key sequence,
but some GSUB rule is applied and unwanted substitution takes place.
The key combinations are:
(i)   (U + 0D24) + (U + 0D4D) + (U + 0D26)
(ii)  (U + 0D2A) + (U + 0D4D) + (U + 0D2E)
(iii) (U + 0D19) + (U + 0D4D) + (U + 0D15)
Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Case (i) - first combination
1.Open Kbabel application
2.Type U + 0D24
3.Type U + 0D4D
4.Type U + 0D26

Case (ii) - second combination
1.Open Kbabel application
2.Type U + 0D2A
3.Type U + 0D4D
4.Type U + 0D2E

Case (iii) - third combination
1.Open Kbabel application
2.Type U + 0D19
3.Type U + 0D4D
4.Type U + 0D15
  
Actual results:
For all the three cases (i),(ii) and (iii) new character(glyph) is obtained

Expected results:
Case(i) : (U + 0D24) + (U + 0D4D) + (U + 0D26)
The display must be according to the key sequence with (U + 0D4D), which is
known as "Chillu", must be on top of (U + 0D24).

Case(ii) : (U + 0D2A) + (U + 0D4D) + (U + 0D2E)
The display must be according to the key sequence with (U + 0D4D) on top of
(U + 0D2A).

Case(iii) : (U + 0D19) + (U + 0D4D) + (U + 0D15)
The display must be according to the key sequence with (U + 0D4D) on top of
(U + 0D19).


Additional info:
Comment 1 Ani Peter 2006-05-25 07:48:49 EDT
Darshan,

Here, case (iiiI need to be omitted, since it must be substituted with a
conjunct and not to be displayed in key sequence. I have made respective change
in the GSUB bug(#192810). You need to look up only on case (i) and (ii).

Comment 2 Ani Peter 2006-05-26 03:31:57 EDT
Description of problem:
Another bug related to GPOS is the positioning problem of CHILLU (0D4D) in the
following combinations. they must be displayed in the key sequence with chillu's
position after first consonant.

(U + 0D16) + (U + 0D4D) + (U + 0D32)      // (shift+key K) + key D + key N 
(U + 0D18) + (U + 0D4D) + (U + 0D32)      // (shift+key I) + key D + key N 
(U + 0D19) + (U + 0D4D) + (U + 0D32)      // (shift+key U) + key D + key N 
(U + 0D1A) + (U + 0D4D) + (U + 0D32)      // key ; + key D + key N 
(U + 0D1B) + (U + 0D4D) + (U + 0D32)      // (shift+key ;) + key D + key N 
(U + 0D1C) + (U + 0D4D) + (U + 0D32)      // key P + key D + key N 
(U + 0D1D) + (U + 0D4D) + (U + 0D32)      //(shift+key P) + key D + key N 
(U + 0D1E) + (U + 0D4D) + (U + 0D32)      // (shift+key ]) + key D + key N 
(U + 0D1F) + (U + 0D4D) + (U + 0D32)      // key ' + key D + key N 
(U + 0D20) + (U + 0D4D) + (U + 0D32)      // (shift+key ') + key D + key N 
(U + 0D21) + (U + 0D4D) + (U + 0D32)      // key [ + key D + key N 
(U + 0D22) + (U + 0D4D) + (U + 0D32)      // (shift+key [) + key D + key N 
(U + 0D23) + (U + 0D4D) + (U + 0D32)      // (shift+key C) + key D + key N 
(U + 0D24) + (U + 0D4D) + (U + 0D32)      // key L + key D + key N 
(U + 0D25) + (U + 0D4D) + (U + 0D32)      // (shift+key L) + key D + key N 
(U + 0D26) + (U + 0D4D) + (U + 0D32)      // key O + key D + key N 
(U + 0D27) + (U + 0D4D) + (U + 0D32)      // (shift+key O) + key D + key N 
(U + 0D28) + (U + 0D4D) + (U + 0D32)      // key V + key D + key N 
(U + 0D2B) + (U + 0D4D) + (U + 0D32)      // (shift+key H) + key D + key N 
(U + 0D2D) + (U + 0D4D) + (U + 0D32)      // (shift+key Y) + key D + key N 
(U + 0D2F) + (U + 0D4D) + (U + 0D32)      // key / + key D + key N 
(U + 0D30) + (U + 0D4D) + (U + 0D32)      // key J + key D + key N 
(U + 0D31) + (U + 0D4D) + (U + 0D32)      // (shift+key J) + key D + key N 
(U + 0D33) + (U + 0D4D) + (U + 0D32)      // (shift+key N) + key D + key N 
(U + 0D34) + (U + 0D4D) + (U + 0D32)      // (shift+key B) + key D + key N 
(U + 0D35) + (U + 0D4D) + (U + 0D32)      // key B + key D + key N 
(U + 0D37) + (U + 0D4D) + (U + 0D32)      // (shift+key ,) + key D + key N 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Kbabel application
2.Type any consonant from the above list say U + 0D1F (press key ')
3.Type U + 0D4D (press key D)
4.Type U + 0D32 (press key N)  
Actual results:
On executing the above steps, the postion of the U + 0D4D moves and is displayed
after U + 0D32

Expected results:
The result of the above must be just according to the key sequence, ie, the U +
0D4D must be after the first consonant (in example , U + 0D1F) instead of U + 0D32.

Additional info:
Comment 3 Leon Ho 2006-08-28 02:16:09 EDT
Please check fonts-malayalam-2.0.1-1 and latest pango for fixes. Can you confirm
what's left to fix?
Comment 4 Ani Peter 2006-08-31 06:51:29 EDT
The above mentioned issue
ie,
The key combinations are:
(i)   (U + 0D24) + (U + 0D4D) + (U + 0D26)
(ii)  (U + 0D2A) + (U + 0D4D) + (U + 0D2E) are wrong is still existing in the
new font
Regards
Ani
Comment 6 Ani Peter 2006-09-14 03:11:00 EDT
Appreciate if you could confirm on comment#4
Comment 7 Rahul Bhalerao 2006-09-25 03:35:48 EDT
The above mentioned problems do not belong to GPOS catagory.
Comment 8 Ani Peter 2006-09-25 03:56:21 EDT
Dear Rahul,

I had submitted this bug when Darshan Santani was present here. He had
categorised the bugs as GSUB and GPOS and then I submitted them according to his
instructions as I am not familiar with the GPOS and GSUB terms and its defenitions.

Thanks
Ani
Comment 9 Ani Peter 2006-09-25 03:59:51 EDT
(forgot to add something in the above comment)

What I was told was that, some unwanted GSUB rule is being used in the above
combination and thus was asked to comment the bug as above (the first box) and
the same was verified by Darshan Santani. 

If any changes needed to be done pelase advice

Thanks
Ani
Comment 10 Rahul Bhalerao 2006-09-26 17:40:28 EDT
This bug has to be submitted as a part of GSUB issues. On other account, the
problem reported in this bug needs a confirmation from language maintainer, Ani
and respective community, since according to government specifications and
general implementations in community, these are not the bugs.
Comment 11 Ani Peter 2006-09-27 02:21:15 EDT
(i)   (U + 0D24) + (U + 0D4D) + (U + 0D26)
(ii)  (U + 0D2A) + (U + 0D4D) + (U + 0D2E)
For the above mentioned two combinations, what output we get in our font is
wrong. Those glpghs are from the old script and the glyphs are correct for other
two combinations. they are 
(a) (U + 0d30) + (U + 0D41)
(b) (U + 0D39) + (U + 0D4D) + (U + 0D2E) respectively. In our font we have used
the new script and hence the result of combinations (a) and (b) are correct.

Thus I conclude that the combinations (i) and (ii) mentioned in this bug must
not reproduce the wrong result as what it does currently. It must be just the
key sequence.

Should I change this under the GSUB issue?
Regards
Ani
Comment 12 Ani Peter 2006-09-27 03:08:08 EDT
However,since these combinations are used very rarely, can set the priority low. 

Thanks
Ani

Comment 13 Rahul Bhalerao 2006-09-28 06:43:20 EDT
Since GPOS issues have been already resolved, the problem stated above will be
reported in some other bug. The original bug is fixed in 2.0.1-1.
Comment 14 Lawrence Lim 2006-09-28 23:09:48 EDT
Which group (Pri A, B, or C) of the bugs does this belong to??
Comment 15 Rahul Bhalerao 2006-09-29 00:21:39 EDT
This is Pri C.
Comment 16 Leon Ho 2006-10-16 07:10:38 EDT
All problem in here should be fixed. QE, Ani please confirm for Rahul
Comment 17 A S Alam 2007-04-27 07:49:56 EDT
Created attachment 153609 [details]
Verified Image
Comment 18 A S Alam 2007-04-27 07:51:14 EDT
Ani,
can you please check and verify, whether you want this as Pango/QT has same output
Comment 19 A S Alam 2007-05-18 07:39:17 EDT
Created attachment 154988 [details]
Updated screenshot
Comment 20 Ani Peter 2007-05-18 08:08:43 EDT
Created attachment 154989 [details]
Correct glyph for gedit/kedit

The glyph in (i) and (ii) and the correct ones for their respective
combinations as shown in screenshot.

Thanks
Ani
Comment 21 A S Alam 2007-05-18 09:36:53 EDT
Based on comment #20, (Translator) mention that bug was not fixed yet, so ASSINED
Comment 22 Rahul Bhalerao 2008-01-23 13:12:25 EST
I am unable to understand the comment #20. 
Ani, can you please make the point clear and let me know the current state of
the problems described in this bug?
Comment 23 Ani Peter 2008-01-24 00:53:35 EST
Rahul,

This bug addresses to problem with two conjunts:

Actual result:
Case 1.a.0D2A + 0D4D + 0D2E gives a wrong conjunct. 
       b.This wrong conjunct must be the result of 0D39 + 0D4D + 0D2E.

Case 2.0D24 + 0D4D + 0D26 gives a wrong conjunct

Expected result:
Case 1.a.0D2A + 0D4D + 0D2E must not give a conjunt instead the output must be
just a key sequence
       b.0D39 + 0D4D + 0D2E must be giving the conjunct that is currently being
formed using the Case 1.a combinations.

Case 2.0D24 + 0D4D + 0D26 must not give a conjunt.

Hope this is clear now. Issue still exist.

Please find the screenshot attached below
Comment 24 Ani Peter 2008-01-24 01:03:28 EST
Created attachment 292728 [details]
screenshot for correct and wrong combinations
Comment 25 Rahul Bhalerao 2008-01-24 02:50:15 EST
Created attachment 292748 [details]
patch for Lohit-Bengali.sfd

This patch fixes the two combinations ligature rules in the .sfd file.
Comment 26 Rahul Bhalerao 2008-01-24 02:50:32 EST
Created attachment 292749 [details]
patch for Lohit-Malayalam.sfd

This patch fixes the two combinations ligature rules in the .sfd file.
Comment 27 Rahul Bhalerao 2008-01-24 02:52:23 EST
Created attachment 292750 [details]
fixed ttf file

Ani, please test this font file before I can build it for fedora.
Comment 28 Ani Peter 2008-01-24 03:46:06 EST
Rahul,

Attached font file tested and all combinations are giving correct results.

Thanks
Ani
Comment 29 Rahul Bhalerao 2008-01-25 07:03:26 EST
Fixed in lohit-fonts-malayalam-2.1.8-1.fc9.
Comment 30 Bug Zapper 2008-05-13 22:10:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Tony Fu 2008-09-09 23:17:45 EDT
requested by Jens Petersen (#27995)
Comment 32 Jens Petersen 2009-05-27 18:40:35 EDT
Closing - please reopen if there should still be any problem.

Note You need to log in before you can comment on or make changes to this bug.