Bug 192820 - Tomboy dies with unhandled exception
Tomboy dies with unhandled exception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk-sharp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 09:16 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 16:11:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-05-23 09:16:58 EDT
Description of problem:
Tomboy dies on first click of system panel icon. This was previously reported as
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191207, but it was
indicated a gtk-sharp issue.

[tbl@localhost plugins]$ tomboy
Trying Plugin: Evolution.dll ... EvolutionPlugin. Done.
Trying Plugin: ExportToHTML.dll ... ExportToHTMLPlugin. Done.
Trying Plugin: PrintNotes.dll ... PrintPlugin. Done.
Tomboy remote control active.
EnableDisable Called: enabling... True
Binding key '<Alt>F12' for '/apps/tomboy/global_keybindings/show_note_menu'
Binding key '<Alt>F11' for '/apps/tomboy/global_keybindings/open_start_here'

Unhandled Exception: System.Reflection.TargetInvocationException: Exception has
been thrown by the target of an invocation. ---> System.InvalidCastException:
Cannot cast from source type to destination type.
in <0x00055> Gtk.Widget:get_GdkWindow ()
in <0x00049> Tomboy.GuiUtils:GetMenuPosition (Gtk.Menu,int&,int&,bool&)
in <0x00063> (wrapper delegate-invoke)
System.MulticastDelegate:invoke_void_Menu_int&_int&_bool& (Gtk.Menu,int&,int&,bool&)
in <0x00068> GtkSharp.MenuPositionFuncWrapper:NativeCallback
(intptr,int&,int&,bool&,intptr)
in <0x00045> (wrapper native-to-managed)
GtkSharp.MenuPositionFuncWrapper:NativeCallback (intptr,int&,int&,bool&,intptr)
in (unmanaged) 0x49423a48
in <0x00004> (wrapper managed-to-native) Gtk.Menu:gtk_menu_popup
(intptr,intptr,intptr,GtkSharp.MenuPositionFuncNative,intptr,uint,uint)
in <0x000de> Gtk.Menu:Popup
(Gtk.Widget,Gtk.Widget,Gtk.MenuPositionFunc,intptr,uint,uint)
in <0x001b4> Tomboy.GuiUtils:PopupMenu (Gtk.Menu,Gdk.EventButton)
in <0x00081> Tomboy.TomboyTrayIcon:ButtonPress (object,Gtk.ButtonPressEventArgs)
in (unmanaged) 0x80b4b8a
in <0x00004> (wrapper managed-to-native)
System.Reflection.MonoMethod:InternalInvoke (object,object[])
in <0x0008d> System.Reflection.MonoMethod:Invoke
(object,System.Reflection.BindingFlags,System.Reflection.Binder,object[],System.Globalization.CultureInfo)
--- End of inner exception stack trace ---

in <0x0010e> System.Reflection.MonoMethod:Invoke (System.Object obj,
BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[]
parameters, System.Globalization.CultureInfo culture)
in <0x0001a> System.Reflection.MethodBase:Invoke (System.Object obj,
System.Object[] parameters)
in <0x000ad> System.Delegate:DynamicInvokeImpl (System.Object[] args)
in <0x00028> System.MulticastDelegate:DynamicInvokeImpl (System.Object[] args)
in <0x0000e> System.Delegate:DynamicInvoke (System.Object[] args)
in <0x00175> GtkSharp.boolObjectEventButtonSignal:boolObjectEventButtonCallback
(IntPtr arg0, IntPtr arg1, Int32 key)
in (wrapper native-to-managed)
GtkSharp.boolObjectEventButtonSignal:boolObjectEventButtonCallback
(intptr,intptr,int)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00007> Gtk.Application:Run ()
in <0x00007> Gnome.Program:Run ()
in <0x00044> Tomboy.Tomboy:StartTrayIcon ()
in <0x00152> Tomboy.Tomboy:Main (System.String[] args)
[tbl@localhost plugins]$


Version-Release number of selected component (if applicable):
gtk-sharp-1.0.10-5
tomboy-0.3.5-4

How reproducible:
every time

Steps to Reproduce:
1. start tomboy
2. click on icon
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2006-05-26 09:59:17 EDT
still fails with tomboy-0.3.5-5
gtk-sharp-1.0.10-5
gtk-sharp2-2.8.2-1
Comment 2 Kenneth Topp 2006-06-05 22:29:16 EDT
fixed upstream: 
   http://bugzilla.gnome.org/show_bug.cgi?id=343453
Comment 3 Bart Vanbrabant 2006-06-06 14:03:32 EDT
The problem is that gtk# 2.8 doesn't work with gtk 2.9

Patches to fix these problems can be found in #194262

A repo with updated versions for rawhide is here:
http://files.zoeloelip.be/rpm/RPMS/

SRPMS here:
http://files.zoeloelip.be/rpm/SRPMS/
Comment 4 Tom London 2006-06-06 16:11:05 EDT
Fixed with gtk2-2.9.2-1

Note You need to log in before you can comment on or make changes to this bug.