Bug 192832 - konsole crashes on kde logout
Summary: konsole crashes on kde logout
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-23 14:35 UTC by long
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 16:50:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash backtrace (3.88 KB, text/plain)
2006-05-23 14:35 UTC, long
no flags Details

Description long 2006-05-23 14:35:46 UTC
Description of problem: konsole seems to randomly crash when I logout of kde. 
The screen goes black and then a window pops up saying konsole had a sigsegv. 
When I log back in the konsole sessions are not restored (as they are when
konsole doesn't crash).


Version-Release number of selected component (if applicable):kdebase-3.5.2-0.1.fc4


How reproducible: Seems more random than not although it seems to be more likely
the more konsole windows I have running when I log out.


Steps to Reproduce:
1. Startup some konsole windows
2. Make sure automatic session saving is on
3. Logout of kde
  
Actual results: will get a black screen and a window saying konsole had a
sigsegv.  After clicking the Close button you get taken back to normal X login
screen.  When I log back in my konsole sessions are not restored


Expected results:  go straight to X login screen.  When you log back in konsole
sessions are restored


Additional info: I'm attaching the backtrace the crash window lets me save.

Comment 1 long 2006-05-23 14:35:46 UTC
Created attachment 129870 [details]
crash backtrace

Comment 2 Ngo Than 2006-05-23 16:50:33 UTC
It seems the bug has been already fixed in KDE upstream (upcomning KDE-3.5.3).
I have backported the fix from KDE svn and added it into kdebase-3.5.2-11 in
rawhide. For FC4 update, I will build new kdebase including this fix soon.

Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.