Bug 192835 - wings segmentation fault at startup
wings segmentation fault at startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wings (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 10:50 EDT by Andreas Meisel
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 13:24:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Meisel 2006-05-23 10:50:30 EDT
Description of problem:

Want to tryout Wings 3D. Wings dies with a segmentation fault at startup.

Version-Release number of selected component (if applicable):

[meisel@localhost ~]$ rpm -q wings
wings-0.98.32b-7.fc5

[meisel@localhost ~]$ rpm -qa | grep erlang
erlang-esdl-0.95.0630-6.fc5
erlang-R11B-0.1.fc5

How reproducible:

always

Steps to Reproduce:
1. Start the wings shortcut "graphics/Wings 3D" -> dies without output
2. Start wings in a console -> segmentation fault output
3.
  
Actual results:

[meisel@localhost ~]$ wings
Erlang (BEAM) emulator version 5.5 [source] [async-threads:0] [hipe]

Eshell V5.5  (abort with ^G)
1> Trying OpenGL modes
  [{buffer_size,32},{depth_size,32},{stencil_size,8},{accum_size,16}]
Actual: RGBA: 2 16 16 16 Depth: 16 Stencil: 16 Accum: 16 16 16 16
Speicherzugriffsfehler

Expected results:

A window with the programm should popup

Additional info:

The stable download from http://www.wings3d.com/ works

[meisel@localhost ~]$ sh wings-0.98.32a-linux.run
Verifying archive integrity... All good.
Uncompressing Wings3D...
Installing Wings 3D 0.98.32a in /home/meisel/wings-0.98.32a
[meisel@localhost wings-0.98.32a]$ sh wings
Trying OpenGL modes
  [{buffer_size,32},{depth_size,32},{stencil_size,8},{accum_size,16}]
  [{buffer_size,24},{depth_size,32},{stencil_size,8},{accum_size,16}]
  [{buffer_size,24},{depth_size,24},{stencil_size,8},{accum_size,16}]
Actual: RGBA: 8 8 8 0 Depth: 24 Stencil: 8 Accum: 16 16 16 16


My first bug report. I hope there are enough informations for you. And sorry for
my bad english ^_^
Comment 1 Gérard Milmeister 2006-05-23 13:08:38 EDT
Yes, I know of this. The problem is the new version of Erlang used
to build against. Strangely I noticed the bug only AFTER the builds
were already in the repositories. I hope, that with a new version
of the ESDL library will fix this soon. Until then, the only
thing you can do is use a previous version of wings and Erlang.
Comment 2 Gérard Milmeister 2006-06-08 13:24:39 EDT
I created a compat-erlang package with the previous version of erlang
and rebuild wings against it. This should work now. Please try this.
The package should hit the repositories in the next few days.
Comment 3 Andreas Meisel 2006-06-16 04:27:15 EDT
Hello, sorry for my late answer. Yes, with your last updates, wings is working
again. Thank you

Note You need to log in before you can comment on or make changes to this bug.