This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 19285 - Re: Minor suggestion
Re: Minor suggestion
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 16:46 EDT by Need Real Name
Modified: 2007-03-26 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 16:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-17 16:46:35 EDT
As a humble suggestion, would someone at RedHat consider building
gcc-2.95.2 RPMs for RedHat 7? I won't argue one way or another, but this
seems like an excellent way to provide choice for users (and silence
critics) Since downgrading the libraries could cause package conflicts,
perhaps these RPMs could be built into /usr/local or some other
non-conflicting directory.

As a side note, I cannot build gcc-2.95.2 from RedHat 7--it fails when
trying to build libio.
Otherwise, I would provide said RPMs myself.

Cheers,
-Geoff Hutchison

Failure of gcc-2.95.2 libio:
/home/hutchisn/build-gcc/gcc/xgcc -B/home/hutchisn/build-gcc/gcc/
-B/usr/local/i686-pc-linux-gnu/bin/ -c -g -O2 -fvtable-thunks -D_GNU_SOURCE
-fno-implicit-templates -I. -I../../../gcc-2.95.2/libio -nostdinc++
-D_IO_MTSAFE_IO ../../../gcc-2.95.2/libio/indstream.cc
../../../gcc-2.95.2/libio/indstream.cc: In method `struct streampos
indirectbuf::seekoff(long long int, ios::seek_dir, int = 3)':
../../../gcc-2.95.2/libio/indstream.cc:82: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:85: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:87: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:89: conversion from `int' to
non-scalar type `streampos' requested
../../../gcc-2.95.2/libio/indstream.cc: In method `struct streampos
indirectbuf::seekpos(_G_fpos64_t, int = 3)':
../../../gcc-2.95.2/libio/indstream.cc:99: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:102: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:104: `struct streampos' used where a
`int' was expected
../../../gcc-2.95.2/libio/indstream.cc:106: conversion from `int' to
non-scalar type `streampos' requested
Comment 1 Jakub Jelinek 2000-12-19 12:49:18 EST
See http://gcc.gnu.org/install/specific.html#*-*-linux-gnu
for fix to make gcc-2.95.2 build under glibc 2.2.

Note You need to log in before you can comment on or make changes to this bug.