Bug 192861 - Database crash everytime unclean shutdown occured
Database crash everytime unclean shutdown occured
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 13:19 EDT by Somsak Sriprayoonsakul
Modified: 2015-01-07 19:12 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0739
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:04:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Somsak Sriprayoonsakul 2006-05-23 13:19:36 EDT
Description of problem:

When an unclean shutdown occured, openldap database always crash due to
incomplete database commit. This make openldap can not start at boot time
(failed to lock database) or openldap can start but query get stuck.

Version-Release number of selected component (if applicable):

How reproducible:
Usually

Steps to Reproduce:
1. kill -9 all slapd
2. Check to see whether /var/lib/ldap/ has __db* files
3. Try start openldap again. See whether the server work properly
  
Actual results:
The server crash

Expected results:
Server run smoothly

Additional info:
Comment 1 Somsak Sriprayoonsakul 2006-05-23 13:21:51 EDT
I modify /etc/init.d/ldap and add db_recover command to recover the database if
unclean commit is detected.

### just before starting daemon ###
if [ -f /var/lib/ldap/__db.001 ]; then
   /usr/bin/db_recover -h /var/lib/ldap
fi
# Start daemons
....
Comment 2 RHEL Product and Program Management 2007-06-19 04:15:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2007-11-15 11:04:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0739.html

Note You need to log in before you can comment on or make changes to this bug.