Bug 192872 - X11 emacs won't start
X11 emacs won't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 14:29 EDT by Braden McDaniel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 10:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2006-05-23 14:29:37 EDT
Description of problem:
X11 emacs does not start.

Version-Release number of selected component (if applicable):
21.4-14

How reproducible:
Consistently

Steps to Reproduce:
1. Start emacs under X11.
  
Actual results:
emacs does not start. The following is printed to the console:

Undefined color: "black"
Comment 1 Chip Coldwell 2006-05-23 14:44:17 EDT
(In reply to comment #0)
> Description of problem:
> X11 emacs does not start.
> 
> Version-Release number of selected component (if applicable):
> 21.4-14
> 
> How reproducible:
> Consistently
> 
> Steps to Reproduce:
> 1. Start emacs under X11.
>   
> Actual results:
> emacs does not start. The following is printed to the console:
> 
> Undefined color: "black"

I doubt this is an emacs bug, as I use 21.4-14 under X11 on FC5 daily.
More likely your X11 config is pooched.

What happens if you try this:

$ xterm -fg white -bg black

?

Chip

Comment 2 Braden McDaniel 2006-05-23 15:01:07 EDT
Indeed:

  Warning: Color name "black" is not defined
  Warning: Color name "white" is not defined


/usr/share/X11/rgb.txt is present and appears intact:

  $ cat /usr/share/X11/rgb.txt | grep black
    0   0   0             black

This is a clean install of FC5, so I'm not sure what could have gone wrong. Any
ideas?
Comment 3 Chip Coldwell 2006-05-23 15:52:04 EDT
(In reply to comment #2)
> Indeed:
> 
>   Warning: Color name "black" is not defined
>   Warning: Color name "white" is not defined
> 
> 
> /usr/share/X11/rgb.txt is present and appears intact:
> 
>   $ cat /usr/share/X11/rgb.txt | grep black
>     0   0   0             black

Check /etc/X11/xorg.conf.  The Files section should look something like this:

Section "Files"
       RgbPath "/usr/share/X11/rgb"
       ModulePath "/usr/lib/xorg/modules"
       FontPath "unix/:7100"
EndSection

Note that the ".txt" suffix is implied, not explicit.

Chip
Comment 4 Chip Coldwell 2006-05-25 10:51:09 EDT
At least, not a bug in emacs.

Chip
Comment 5 Braden McDaniel 2006-05-25 11:00:19 EDT
Indeed. The problem was that my xorg.conf had been migrated from a previous
installation and consequently had a bogus entry for RgbPath. Thanks for pointing
me in the right direction.

Note You need to log in before you can comment on or make changes to this bug.