Bug 192879 - f-spot fails on start up with System.NullReferenceException
f-spot fails on start up with System.NullReferenceException
Status: CLOSED DUPLICATE of bug 192595
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 15:22 EDT by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 13:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-05-23 15:22:10 EDT
Description of problem:

[david@localhost ~]$ f-spot
Starting new FSpot server
System.NullReferenceException: Object reference not set to an instance of an object
in <0x0002f> Gtk.Widget:set_GdkWindow (Gdk.Window value)
in <0x00049> FSpot.GroupSelector:OnRealized ()
in <0x00053> Gtk.Widget:realized_cb (IntPtr widget)
in (wrapper native-to-managed) Gtk.Widget:realized_cb (intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Box:gtk_box_pack_start
(intptr,intptr,bool,bool,uint)
in <0x00073> Gtk.Box:PackStart (Gtk.Widget child, Boolean expand, Boolean fill,
UInt32 padding)
in <0x00b06> MainWindow:.ctor (.Db db)
in <0x00046> FSpot.Core:get_MainWindow ()
in <0x00012> FSpot.Core:Organize ()
in <0x0071f> FSpot.Driver:Main (System.String[] args)

(f-spot:2257): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height
>= -1' failed

(f-spot:2257): Gdk-CRITICAL **: gdk_window_invalidate_maybe_recurse: assertion
`window != NULL' failed

(f-spot:2257): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion `height
>= -1' failed

(f-spot:2257): Gdk-CRITICAL **: gdk_window_invalidate_maybe_recurse: assertion
`window != NULL' failed

Unhandled Exception: System.NullReferenceException: Object reference not set to
an instance of an object
in <0x000eb> FSpot.GroupSelector:set_Offset (Int32 value)
in <0x005f1> FSpot.GroupSelector:OnSizeAllocated (Rectangle alloc)
in <0x0007f> Gtk.Widget:sizeallocated_cb (IntPtr widget, Gdk.Rectangle allocation)
in (wrapper native-to-managed) Gtk.Widget:sizeallocated_cb (intptr,Gdk.Rectangle&)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Dialog:gtk_dialog_run (intptr)
in <0x00031> Gtk.Dialog:Run ()
in <0x007c6> FSpot.Driver:Main (System.String[] args)

Version-Release number of selected component (if applicable):
f-spot-0.1.11-1


How reproducible:
100%

Steps to Reproduce:
1. run f-spot from a terminal
  
Actual results:
Appended traceback

Expected results:
running f-spot
Comment 1 Stewart Adam 2006-05-25 19:37:32 EDT
I'm seeing near same thing:
System.NullReferenceException: Object reference not set to an instance of an object
in <0x00019> Gtk.Widget:set_GdkWindow (Gdk.Window value)
in <0x00038> FSpot.GroupSelector:OnRealized ()
in <0x00036> Gtk.Widget:realized_cb (IntPtr widget)
in (wrapper native-to-managed) Gtk.Widget:realized_cb (intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Box:gtk_box_pack_start
(intptr,intptr,bool,bool,uint)
in <0x0004b> Gtk.Box:PackStart (Gtk.Widget child, Boolean expand, Boolean fill,
UInt32 padding)
in <0x00966> MainWindow:.ctor (.Db db)
in <0x0002a> FSpot.Core:get_MainWindow ()
in <0x00016> FSpot.Core:Import (System.String path)
in <0x00514> FSpot.Driver:Main (System.String[] args)

I think it's related. I'm in FC5, though, not devel.
Fireiwng1
Comment 2 Bart Vanbrabant 2006-06-06 14:16:28 EDT
This one is a duplicate of #192595
I posted a fix there.
Comment 3 Matthias Clasen 2006-07-25 13:19:45 EDT

*** This bug has been marked as a duplicate of 192595 ***

Note You need to log in before you can comment on or make changes to this bug.