Bug 1929 - RFE: more intelligent makewhatis.cron
RFE: more intelligent makewhatis.cron
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
5.2
All Linux
low Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-01 03:18 EST by Chris Siebenmann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-09 19:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Siebenmann 1999-04-01 03:18:37 EST
Right now, the whatis indexes are only rebuild weekly,
presumably because it's a heavy-duty procedure; this can
be a long wait in some circumstances.

 It would be nice if makewhatis.cron (or makewhatis
itself) was more intelligent, and only rebuilt the
whatis indexes if they were out of date. Then it would
be sensible to run makewhatis.cron more often, such as
every night.
Comment 1 David Lawrence 1999-04-01 16:46:59 EST
Thank you for your suggestion. This has been passed on to a developer.
Comment 2 Michael K. Johnson 1999-04-09 18:22:59 EDT
Seems like a weekly script to rebuild the database and a daily
script to update the database would be about right...
Comment 3 Michael K. Johnson 1999-04-09 19:29:59 EDT
Fixed in man-1.5g-2.  makewhatis already had a -u option for
doing fast updates to the database.  There's now a weekly
script that recreates the database and a daily script that
updates it very quickly.  makewhatis itself already had all
the needed intelligence -- we just needed to harness it.
We wouldn't want to avoid rebuilding the database once a week
because the updates aren't sorted, just appended, and over
time an actively-maintained system would end up with a rather
messed-up database providing essentially random apropos output...

Thanks for the suggestion!

Note You need to log in before you can comment on or make changes to this bug.