Bug 192928 - undefined symbol
undefined symbol
Status: CLOSED DUPLICATE of bug 196895
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 06:10 EDT by Ottavio G. Rizzo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 17:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase pdf (49.73 KB, application/pdf)
2006-05-24 09:06 EDT, Ottavio G. Rizzo
no flags Details

  None (edit)
Description Ottavio G. Rizzo 2006-05-24 06:10:36 EDT
Description of problem:

Evince crashes at start-up with an undefined symbol lookup error

Version-Release number of selected component (if applicable): 0.5.3-1


How reproducible: just invoke evince


Steps to Reproduce:
1. evince
  
Actual results:

[otto@amelia mepvs]$ evince
evince: symbol lookup error: evince: undefined symbol: g_type_register_static_simple


Additional info: This was the only package from development I installed on my
fc5 machine. I tried installing also poppler, but to no aval. I even tried to
recompile the .src package, but the process ended with 

/usr/lib/gcc/i386-redhat-linux/4.1.0/../../../libpoppler-glib.so: undefined
reference to `g_type_register_static_simple'
collect2: ld returned 1 exit status


I suppose this is a simple case of dependency not listed correctly
Comment 1 Ottavio G. Rizzo 2006-05-24 09:06:49 EDT
Created attachment 129927 [details]
Testcase pdf
Comment 2 Ottavio G. Rizzo 2006-05-24 09:17:15 EDT
I recompiled poppler-0.5.2-1, and then I managed to recompile evince-0.5.3-1.

The problem is, it doesn't work: now, evince cannot grok the Type3 fonts
inserted by TeX: see the attached pdf file

Notice that xpdf works fine, as did evince-0.5.1-3.i386.rpm
Comment 3 Ottavio G. Rizzo 2006-05-24 09:27:12 EDT
I made other tests: the problem lies in poppler-0.5.2-1.

Indeed, with poppler-0.5.2, both versions of evince don't work as expected.
With poppler poppler-0.5.1-2, both versions of evince do work as expected.
Comment 4 Kristian Høgsberg 2006-06-29 17:13:37 EDT

*** This bug has been marked as a duplicate of 196895 ***

Note You need to log in before you can comment on or make changes to this bug.