Bug 19293 - "-rwsr-xr-x" for ssh?
Summary: "-rwsr-xr-x" for ssh?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0J
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 00:31 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-20 20:49:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-18 00:31:05 UTC
After upgrading default openssh on RH7.0
using openssh-clients-2.2.0p1-5.i386.rpm,
I noticed /usr/bin/ssh has protection mode as
"-rwsr-xr-x". Is this a feature or a bug?
I don't think allow ing ssh start on privilaged port
is a good idea.

Comment 1 Daniel Roesen 2000-10-18 12:14:53 UTC
I agree that the ssh client should NOT be setuid-root by default.

Comment 2 Pekka Savola 2000-10-19 18:49:30 UTC
setuid bit is required for RSAAuthentication and RhostsRSAAuthentication.

Comment 3 Daniel Roesen 2000-10-19 18:55:18 UTC
Only for RhostsRSAAuthentication, not RSAAuthentication. Otherwise I must be
doing something wrong, because RSA Auth works perfectly without suid bit set on
the client. :-]

Comment 4 Pekka Savola 2000-10-20 20:49:01 UTC
Oh.  You're correct :-)


Comment 5 Nalin Dahyabhai 2000-10-24 19:22:43 UTC
All of the above.  Any kind of RHosts authentication is based on the client
connecting from a "privileged" port, and ssh needs to be setuid in order to do
this correctly.


Note You need to log in before you can comment on or make changes to this bug.