This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 192960 - tetex-preview files conflict with tetex-latex
tetex-preview files conflict with tetex-latex
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs-auctex (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
: Reopened
Depends On: 193069
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 10:54 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-18 14:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-05-24 10:54:44 EDT
Description of problem:

Transaction Check Error:   file /usr/share/texmf/tex/latex/preview/prauctex.cfg
from install of tetex-preview-11.82-10.fc4 conflicts with file from package
tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prauctex.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prcounters.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/preview.sty from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prfootnotes.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prlyx.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prshowbox.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prshowlabels.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prtightpage.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4
  file /usr/share/texmf/tex/latex/preview/prtracingall.def from install of
tetex-preview-11.82-10.fc4 conflicts with file from package tetex-latex-3.0-9.FC4

On i386, the package installs, but files are still owned by both:

# rpm -qf /usr/share/texmf/tex/latex/preview/prauctex.cfg
tetex-latex-3.0-9.FC4
tetex-preview-11.82-10.fc4
Comment 1 Ed Hill 2006-05-24 13:19:44 EDT
Hi Orion, this problem was caused by Jonathan Underwood's recent changes 
so I'm assigning the bug to him (and adding myself to the cc: list).
Comment 2 Jonathan Underwood 2006-05-24 13:50:08 EDT
Ah, damn.

I thought these conflicts (due to preview being packaged with tetex) had been
fixed by the tetex packager - seems he only fixed them for FC-5 - will fix it
shortly. Apologies.
Comment 3 Jonathan Underwood 2006-05-24 14:51:46 EDT
Actually, Orion - I am a bit confused by your report - if it installs on i386,
what are those transaction errors from? 64 bit? The packages (both auctex, and
tetex-latex) should be the same on either arch. Are you sure you had the latest
tetex packages installed on both arcs - they are on build 19 on FC5. Alas I
don't have access to an FC4 box.

For safety I'll revert the change which produces the tetex-latex package for
FC4, but if you could clarify on those points, it will be helpful.
Comment 4 Orion Poplawski 2006-05-24 15:33:21 EDT
Transaction errors are on a x86_64 box (hence the arch of the bug).  Versions
are listed in the errors, and are up to date.

I really don't know why I didn't get conflicts on the i386 boxes, as now the
tetex-latex package is not correct:

root@orca ~]# rpm -V tetex-latex
S.5....TC   /usr/share/texmf-var/web2c/latex.fmt
S.5....TC   /usr/share/texmf-var/web2c/pdflatex.fmt
S.5....T. c /usr/share/texmf/tex/latex/preview/prauctex.cfg
S.5....T.   /usr/share/texmf/tex/latex/preview/prauctex.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prcounters.def
S.5....T.   /usr/share/texmf/tex/latex/preview/preview.sty
S.5....T.   /usr/share/texmf/tex/latex/preview/prfootnotes.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prlyx.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prshowbox.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prshowlabels.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prtightpage.def
S.5....T.   /usr/share/texmf/tex/latex/preview/prtracingall.def

Perhaps a rpm bug dealing with noarch/arch packages as well?  I've filed bug
#193046 against rpm.
Comment 5 Jonathan Underwood 2006-05-24 15:43:47 EDT
OK thanks for the info.

For reference, this is the bug that led me to believe these files had been
removed from the tetex-latex package: Bug #168859

Comment 6 Jonathan Underwood 2006-05-24 16:44:58 EDT
OK, have pushed a rebuild of the package which no longer exports a tetex-preview
sub-package, and so no longer installs anything into the texmf tree. 

To undo the damage the main package Obsoletes and Provides tetex-preview. That
will remove the "bad" package from users sytems when they updat.e Alas, they'll
have to freshen the tetex-latex package to undo the damage caused by the rpm bug. 

This of course means we can't push a package for tetex-preview for FC4 in the
future (and it may also cause tetex-preview not to be installed on systems which
have upgraded from FC4 with emacs-auctex installed). This seemed like the best
damage limitation in the circumstaces.

Comment 7 Orion Poplawski 2006-05-26 11:49:05 EDT
I think you need to use the FC4Status wiki page to pull the old tetex-preview
out of the repository.
Comment 8 Jonathan Underwood 2006-05-27 10:24:39 EDT
Thanks for the reminder Orion - have done so.

This issue should  now be fixed, so will close this bug - please reopen if there
are further problems. Thanks.
Comment 9 Michal Jaegermann 2006-06-08 10:52:51 EDT
Now the problem is that the current update of tetex for FC4 dropped
files from /usr/share/texmf/tex/latex/preview/.  Of course if
emacs-auctex was not installed then no functionality was lost because
these files did not make much sense on their own.  The picture is
clearly different if emacs-auctex was on the system and there is
no replacement (save tetex-preview package from FC5 extras which will
work just fine).  Is it possible to automatically trigger an installation
of tetex-preview, when available again, on updates?  FC4 version of
tetex-preview may require high enough version of tetex to avoid conflicts.

In other words - a coordination mess.

Oh, and /usr/share/texmf/doc/latex/styles/preview.dvi is gone from FC4
updated packages too.
Comment 10 Jonathan Underwood 2006-06-08 11:04:15 EDT
To recap:

1) The preview files included in tetex were incomplete, and the intention was to
remove them.

2) Since I thought the files in 1) above were gone, I built the tetex-preview
package from auctex sources to dump the files into the texmf tree.

3) We then find the files from tetex mention in 1) aren't gone, and so a problem
occurs. And worse, due to a bug in rpm, the transaction doesn't fail.

4) The only way to fix this, because of the rpm bug, is to stop building the
tetex-preview package and install the preview functionality for emacs/auctex
into the site-lisp tree (as mandated by auctex), AND have auctex Obsolotes and
Provide tetex-preview. 


So, now that the corrected tetex packages have been pushed for update, we could
build tetex-preview again for FC4, requiring the latest tetex packages. That
means though that auctex install would fail if the user doesn't have the latest
tetex packages.

Alternatively, we could just leave it as is, and the preview functionality in
AucTex still works, just that the preview functionality isn't available to eg. Lyx.

[And no, it's not a coordination mess.]

Michal - why exactly do you want us to push tetex-preview again? If the reasons
are good, we can do it. But in order to not result in a broken system, the
updated auctex package will need to Require tetex-preview = %version-%release,
as the current Auctex package has Provides: tetex-preview. I am tempted to leave
it alone, therefore.
Comment 11 Jonathan Underwood 2006-06-08 11:05:16 EDT
ps. Bare in mind that the rpm bug that led to the complications with this issue
hasn't been fixed.
Comment 12 Michal Jaegermann 2006-06-08 11:29:19 EDT
> Michal - why exactly do you want us to push tetex-preview again?

I do not care that much how things are packaged; although one would
think that maintaining a similar structure for FC4 and FC5 extras
has advantages for all parties involved.  What I do care is that
preview in emacs was working before and now it got broken as
essential pieces vanished.  It seems that both tetex and emacs-auctex
dropped them in approximately the same time.  OTOH lyx depends on
emacs-auctex with all consequences.

That LyX can, or it might at some moment, do something similar like
preview is not here not there.
Comment 13 Jonathan Underwood 2006-06-08 11:37:38 EDT
> What I do care is that preview in emacs was working before and now
> it got broken as essential pieces vanished.

That should not be the case - the current packages still have the preview
functionality enabled for emacs/auctex - the preview stuff is installed inside
the site-lisp tree. Please can you confirm that the preview functionality is not
working when you run emacs -Q. Thanks.
Comment 14 Jonathan Underwood 2006-06-08 11:57:47 EDT
Sorry. I meant:

Please can you confirm that the preview functionality is missing from emacs when
you run emacs -q.
Comment 15 Michal Jaegermann 2006-06-08 12:54:19 EDT
Oh, I see.  I missattributed the problem (I have now only "remote"
FC4 installation where I can check what is happening).

After all current updates on FC4 when I loaded a LaTeX file in emacs
"Preview" did not show up among emacs menus so I assumed that it
is missing.  Closer check of '*Messages*' buffer found lines like

File mode specification error: (wrong-type-argument symbolp (cdr cell))
byte-code: Wrong type argument: stringp, nil

The later error was actually showing up always on attempts to
load .../site-start.d/preview-latex.el.

After throwing away all .elc files from /usr/share/emacs/site-lisp/auctex
directory all these errors disappeared and preview started to work
again.  Closer examination showed that "removed" preview files are now
on FC4 at a different location.

I have seen errors caused by byte-compiled files before.  No idea what
is really wrong here, and attempts to debug turned out to be futile,
but loading .el sources instead invariably was fixing such issues and
on current machines possible time differences are for me in practice
invisible.
Comment 16 Jonathan Underwood 2006-06-08 13:30:57 EDT
Removing the compiled lisp files should not have been necessary to fix the problem.

Did you try emacs -q ?

I suspect your .emacs file might be trying to load preview-latex.el explicitly -
is that the case? (It is not necessary, or adviseable, to be loading
preview-latex.el from your .emacs file)

Unfortunately, I can't tell if this is a bug with the package or not from the
information you have given.
Comment 17 Michal Jaegermann 2006-06-08 14:04:50 EDT
> Did you try emacs -q ?

Not loading init files is not really an option; but my ~/.emacs is
not long or complicated. :-)  Nearly all is written by "Customize emacs"
anyway.

> I suspect your .emacs file might be trying to load preview-latex.el explicitly

This is not the case.

Anyway, I restored .elc files and tried 'emacs -q'.  I got

File mode specification error: (wrong-type-argument symbolp (cdr cell))

and no preview; with or without '-q'.

Once I removed these .elc files again things work correctly again.
Comment 18 Jonathan Underwood 2006-06-08 19:30:13 EDT
OK, thanks for checking with emacs -q.

I am a bit baffled by this. This behaviour isn't anything to do with the
preview.sty stuff, but the lisp end of things, so the package changes shouldn't
have caused this. Are you using emacs as shipped with FC4? Is there anything
non-standard that you're using? Did you byte compile the elc files yourself or
reinstall them from the rpm ?

I'll look at rebuilding a package to push tetex-preview again, with proper
version-release dependencies, but I am not sure that will help this issue. When
exactly did you see this problem begin?

Please give the outputs of
rpm -qa | grep emacs
rpm -qa | grep auctex
rpm -qa | grep tetex

Thanks.
Comment 19 Jonathan Underwood 2006-06-08 20:16:56 EDT
I have now pushed builds which once again produce a tetex-preview subpackage as
before. 11.82-12. These require the latest updates of tetex from Core. 
Comment 20 Jonathan Underwood 2006-06-18 14:25:09 EDT
I am re-closing this bug, as I believe the issue is resolved (although I note a
number of postings have been lost from the bugzilla in the hardware crash).

Please open a new bug report if there are still issues. Thanks.

Note You need to log in before you can comment on or make changes to this bug.