Bug 192967 - x apps can't find colors
Summary: x apps can't find colors
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 5
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-24 15:34 UTC by Robert Story
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 17:24:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Story 2006-05-24 15:34:46 UTC
Description of problem:
ddd spews warnings about colors on startup. eg:

Warning: Color name "white" is not defined
(Annoyed?  Try 'Edit->Preferences->General->Suppress X Warnings'!)
Warning: Color name "DarkGreen" is not defined
Warning: Color name "red4" is not defined
XPM: ddd.xpm: no color found
Warning: Color name "grey96" is not defined

Unfortunately, the suggested setting (Supress X Warnings) has no effect.
Besides, I _want_ the colors.


Version-Release number of selected component (if applicable):
ddd-3.3.11-5.2

How reproducible:
Always. Tried existing user (w/ ~/.ddd dir, and new user w/out one).

Steps to Reproduce:
1. start ddd
2.
3.
  
Actual results:
lots of warnings, no colores in ddd

Expected results:
no warnings, colors in ddd.

Additional info:
I'm usually available in #fedora-ppc as rstory, for questions/testing.

Comment 1 Ngo Than 2006-05-24 15:43:54 UTC
it seems a bug xorg-x11. Do you see this warnings by starting other apps,
for example: xterm, gimp?

Comment 2 Robert Story 2006-05-25 16:32:59 UTC
I tried xterm and gimp. Nothing from gimp, but xterm did indeed complain:

Warning: Color name "black" is not defined
xterm: Cannot allocate color magenta3
xterm: Cannot allocate color magenta


updated summary and changed component to xorg-x11.

Comment 3 Robert Story 2006-05-26 17:24:37 UTC
google figured this oen out for me... I had copied xorg.conf from my fc4 system,
and the RGB path has changed. Once I fixed that, colors are now working...


Note You need to log in before you can comment on or make changes to this bug.