Bug 192979 - FC5 installation on HP NetServer E800 fails due to spinlock bad magic BUG
FC5 installation on HP NetServer E800 fails due to spinlock bad magic BUG
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://Bolizm.ihep.su/photo/192979/
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 12:25 EDT by QingLong
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 19:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description QingLong 2006-05-24 12:25:15 EDT
Description of problem:
There is a &%#^%$ HP #&$^* NetServer E800 which I have to install FC5 on.
Installation process hangs during (or just after?) video system probe:

   Running anaconda, the Fedora ......
   Probing for video card: ATI Technologies Inc Rage XL
   Probing for monitor type: Unknown monitor

   BUG: spinlock bad magic on CPU#0, anaconda/569
    lock: c040d32c, .magic: 00000000, .owner: <none>/-1, .owner_cpu: 0

Well, maybe this a kernel (or even hadrware) problem, rather than anaconda one,
I am just in doubt.

Version-Release number of selected component (if applicable):
Fedora Core 5 CD#1 (first disc in installation pack),
made from original iso image.

How reproducible:
100%.
I have tried to workaraound it giving various options
(in various combiinations):
   noprobe
   skipddc
   text
   nosmp

Steps to Reproduce:
1. Get a fscken HP damned NetServer E800
2. Insert Fedora Core 5 disk #1
3. Launch the installation process
  
Actual results:
The installation process stops and the system becomes stuck
(see the diagnostic above)

Expected results:
The process should in result in working Fedora Core 5 system.

Additional info:
Rescue disk from the same Fedora Core 5 CD pack works fine.
I suppose it's due to it doesn't try to probe the video subsystem.
Comment 1 QingLong 2006-05-25 05:15:57 EDT
It looks like this is not an anaconda bug,
it appears to be a kernel/hardware bug.
After a day of monkeying with kernel options
I have found a workaround (quite standard, though):
      acpi=off
So I guess, the bug report should be redirected to kernel developers.
Comment 2 QingLong 2006-05-25 09:42:02 EDT
More details:
After installation the kernel without `acpi=off' option starts quite fine
and the system startup curve goes well till cups.
On starting the cups daemon kernel panics.
Amongst lots of printed symbols there surely are `spin' related ones,
so I think that's the same `spinlock' issue.
The `acpi=off' kernel option does fix the problem.
Comment 3 Dave Jones 2006-10-16 16:18:28 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 QingLong 2006-10-17 04:42:34 EDT
I just have tried the 2.6.18-1.2200.fc5.
The bug is still there: without acpi=off kernel panics on HAL daemon start
(while probing serial ports). The acpi=off workaround helps.
Comment 5 Dave Jones 2006-10-19 14:18:33 EDT
can you capture the panic from the latest kernel and dump that here ?
(even a digital photograph will be fine if you have access to a camera)

if the panic makes info scroll off the top of the screen, booting with vga=1
will fit more lines of text on the screen.

Also, do you have any 3rd party modules installed ?
Comment 6 QingLong 2006-10-20 07:55:06 EDT
I've shot it. See http://Bolizm.ihep.su/photo/192979/.
There are no 3rd party modules installed.
BTW, vga=1 doesn't help as initscripts load console font of default size.
If you need the real dump (kernel-kdump or a serial console log?)
it will take more time.
Comment 7 QingLong 2006-11-14 08:44:58 EST
The bug is still there in FC6 stock kernel (2.6.18-1.2798.fc6.i586).
Comment 8 QingLong 2006-12-19 03:11:56 EST
It looks like the bug is absent in kernel-2.6.18-1.2849.fc6.i586
(no kernel panic had occured during the whole runtime).
I just have switched from it to the new kernel-2.6.18-1.2868.fc6.i586,
shall watch it for a while too.
Comment 9 QingLong 2007-01-15 10:09:59 EST
Both 2.6.18-1.2868.fc6.i586 and 2.6.18-1.2869.fc6.i586 appear to be OK.
BTW, why the FC6 installation scripts have installed the i586.rpm package
while the CPU has been Pentium III (Coppermine)?
Can/should I manually replace it by the i686.rpm package?
Maybe the i686.rpm would be more adequate for the PIII CPU?
Comment 10 Bug Zapper 2008-04-03 22:58:09 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 QingLong 2008-04-08 08:49:02 EDT
>
> We strongly encourage you to upgrade to a current Fedora release.
>
   To my regret I cannot upgrade to a later Fedora release as since Fedora 7
PATA disks are always treated as SCSI via ide-scsi emulation
and SCSI disks cannot contain more than 15 partitions,
while I do have more than twenty of them.
It seems I would have to change Linux distribution.
Comment 12 John Poelstra 2008-04-10 19:05:39 EDT
Thanks for your update

Note You need to log in before you can comment on or make changes to this bug.