Bug 19298 - 7.0 won't install if there's RAID
7.0 won't install if there's RAID
Status: CLOSED DUPLICATE of bug 18900
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 21:56 EDT by sean
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 17:44:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2000-10-17 21:56:17 EDT
I'm trying to upgrade 6.2 to 7.0. A directory  /home/nhi  is mounted on a
RAID1 device. As far as I figure out from this traceback, that seems to
buffalo the installer.

I suppose that commenting  /home/nhi  out of fstab would work, but I've got
a bunch of remote machines.  Is RAID really the problem?  Is there a
workaround?

thanks

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in
run
    rc = apply (step[1](), (dir,) + step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in
__call__
    todo.upgradeFindPackages (root)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 910, in
upgradeFindPackages
    fstab.readFstab('/mnt/sysimage/etc/fstab', self.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 1028, in
readFstab
    fields[2], raidByDev[int(fields[0][7:])])
KeyError: 0

Local variables in innermost frame:
loopIndex: {}
fstab: <fstab.NewtFstab instance at 8216428>
labelsByMount: {'/': 'hda2', 'NHI': 'hdc7', 'backup': 'hdc2', 'var':
'hdc6', '/usr': 'hda3', 'usr': 'hda5', 'tmp': 'hdc5'}
line: /dev/md0   /home/nhi    ext2   defaults    0  2

path: /mnt/sysimage/etc/fstab
device: hdc6
raidByDev: {}
fsystem: ext2
drives: ['hda', 'hdb', 'hdc']
lines: ['/dev/hda2  / ext2 defaults 0 1\012', 'none /proc proc defaults  0
0\012', 'none   /dev/pts devpts  gid=5,mode=620        0 0\012', '/dev/hda1
/boot ext2 defaults 0 2\012', '#/dev/hda3 /usr ext2 defaults  0  2\012',
'/dev/hda5 /usr ext2 defaults  0  2\012', '/dev/hdc1 none swap defaults 0
2\012', '/dev/hdc2 /etc/backup  ext2  defaults  0  2\012', '/dev/hdc5 
/tmp      ext2     defaults   0   2\012', '/dev/hdc6   /var        ext2   
defaults   0   2\012', '/dev/md0   /home/nhi    ext2   defaults    0 
2\012']
labels: {'hda5': 'usr', 'hda6': 'NHI', 'hda2': '/', 'hda3': '/usr', 'hdc6':
'var', 'hdc7': 'NHI', 'hdc5': 'tmp', 'hdc2': 'backup'}
fields: ['/dev/md0', '/home/nhi', 'ext2', 'defaults', '0', '2']
f: <open file '/mnt/sysimage/etc/fstab', mode 'r' at 820cb40>
raidList: []

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-19 17:44:19 EDT
There have been a few reports like this -  we will look into it.

*** This bug has been marked as a duplicate of 18900 ***

Note You need to log in before you can comment on or make changes to this bug.