Bug 192982 - Error in spec file -- wrong condition in `find' command
Error in spec file -- wrong condition in `find' command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 12:35 EDT by Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 15:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this simply adds the missing parentheses as described in the `Additional info' section (422 bytes, patch)
2006-05-24 12:45 EDT, Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
no flags Details | Diff

  None (edit)
Description Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-05-24 12:35:47 EDT
Description of problem:

There's a `find' command call in the spec file, which takes care of deleting the
"garbage" left after applying the patches. This commands is supposed to delete
files matching the shell patterns `*.orig' or `*~'. This means files matching
the first *or* the second pattern. The way the condition is written, the `or'
became to `and', which obviously means no files get removed as these patterns
are mutually exclusive.


Version-Release number of selected component (if applicable):

2.6.16-1.2208_FC6 (kernel-2.6.16-1.2208_FC6)


How reproducible:

always


Steps to Reproduce:

1. Run e. g. `rpmbuild --target i686 -bp kernel-2.6.spec'.
2. Look for files matching `*.orig' -- you'll find several ones.

  
Actual results:

There's a lot of "garbage" (ie. files with the `.orig' suffix) left under the
build tree.


Expected results:

This "garbage" should have been deleted at the end of prep stage.


Additional info:

The format of `find' command has changed compared to CentOS (which I believe
corresponds to some older FC). Someone forgot to add parentheses around the `or'
part.

This bug may have existed for some time. Don't want to look into this furter, I
believe filing a bug against the latest devel SRPM is sufficient.

Patch will be provided immediately...
Comment 1 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-05-24 12:45:24 EDT
Created attachment 129951 [details]
this simply adds the missing parentheses as described in the `Additional info' section
Comment 2 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-05-24 12:56:36 EDT
In fact there's still a little garbage left after this fix: Under the build
tree, a  file `kernel-2.6.16/xen/common/sched_sedf.c.orig' still survives, but I
think this is because the `xen' subdirectory is not taken care of. So,
obviously, further cleanup might have to be implemented.
Comment 3 Dave Jones 2006-05-25 15:10:10 EDT
thanks, fixed in cvs, should be in tomorrows build.
Comment 4 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-05-28 18:39:46 EDT
Was glad to help. :-)

In fact, I noticed this small bug while analysing kernel SRPMs for CentOS/RHEL,
for which I also included latest FC SRPM.

Note You need to log in before you can comment on or make changes to this bug.