Bug 193082 - bcm43xx driver don't work for me in rawhide
bcm43xx driver don't work for me in rawhide
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 20:36 EDT by Joshua Wulf
Modified: 2014-10-19 18:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 14:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full patch between the FC5 snapshot and the version which was merged. (198.54 KB, patch)
2006-05-24 21:34 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description Joshua Wulf 2006-05-24 20:36:48 EDT
Description of problem: The bcm43xx driver no longer associates with my access
points in the rawhide kernels on my G4 ibook. I use kernel-2.6.16-1.2096_FC5 to
 get wireless going. Everything else in the rawhide tree up to
kernel-2.6.16-1.2211_FC6 is b0rked for me.

Version-Release number of selected component (if applicable):
all rawhide kernels up to and including 2.6.16-1.2211_FC6

How reproducible:
100%

Steps to Reproduce:
1. Boot to the kernel
2. Try to associate with a WAP
3.
  
Actual results:
Here is the relevant dmesg output:

bcm43xx driver
PCI: Enabling device 0001:10:12.0 (0004 -> 0006)
bcm43xx: Chip ID 0x4318, rev 0x2
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0xd, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x9, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x804, rev 0xc, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x80d, rev 0x7, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 3, Type 2, Revision 7
bcm43xx: Detected Radio: ID: 8205017f (Manuf: 17f Ver: 2050 Rev: 8)
bcm43xx: Radio turned off
bcm43xx: Radio turned off

later....


bcm43xx: PHY connected
bcm43xx: Radio turned on
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: Chip initialized
bcm43xx: DMA initialized
bcm43xx: 80211 cores initialized
bcm43xx: Keys cleared
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
ADDRCONF(NETDEV_UP): eth1: link is not ready
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
SoftMAC: Scanning finished
SoftMAC: Queueing Authentication Request to 02:12:f0:00:00:5e
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Queueing Authentication Request to 02:12:f0:00:00:5e
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
ADDRCONF(NETDEV_UP): dev1804289383: link is not ready
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Sent Authentication Request to 02:12:f0:00:00:5e.
SoftMAC: Authentication timed out with 02:12:f0:00:00:5e
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Authentication timed out with 02:12:f0:00:00:5e
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: cannot associate without being authenticated, requested authentication
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished


then there are a whole swag of avc denied SELinux messages, mostly involving
DBus (SELinux is permissive on my system), then a  whole lot of this:

SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.
SoftMAC: Authentication response received from 00:12:f0:02:e3:45 but no queue
item exists.


Expected results:
In the 2096 kernel I just boot up and it's associated and with an IP address,
auto-magically.

Additional info:
Comment 1 David Woodhouse 2006-05-24 21:32:15 EDT
This is a regression which was introduced between the snapshot of bcm43xx which
we put in FC5, and the version which was first merged into 2.6.16-git18.

Joshua, you were going to try versions of the driver from SVN to see precisely
which change was responsible -- how far did you get with that?
Comment 2 David Woodhouse 2006-05-24 21:34:03 EDT
Created attachment 129973 [details]
Full patch between the FC5 snapshot and the version which was merged.
Comment 3 Joshua Wulf 2006-05-25 03:48:36 EDT
Don't hold your breath for it, I'm trying to find someone who can show me how to
do that, who has time to do it - when I have time to do it....

Am I the only one seeing this?
Comment 4 John W. Linville 2006-05-25 14:31:17 EDT
The patch from comment 2 is a little big to be helpful.

Before digging too deeply, it might be nice for you to try the FC5.netdev.3 
kernels from here:

   http://people.redhat.com/linville/kernels/fedora-netdev/5/rpms

Could you give those a try to make sure the problem still exists there?
Comment 5 David Woodhouse 2006-05-25 14:59:42 EDT
(In reply to comment #4)
> The patch from comment 2 is a little big to be helpful.

Yeah, just a little. Nevertheless, it's what we have -- that's the difference
between the last known good, and the first known broken -- I talked Joshua
through using git for that, and we established that bcm43xx was broken before it
got merged to Linus.

The next step is to build from the old bcm43xx SVN tree (or maybe the daily
snapshots if they're still available) and track it down further.

I cannot reproduce this here.
Comment 6 Joshua Wulf 2006-05-29 22:53:31 EDT
With 2.6.16-1.2122.2.3_FC5.netdev.3 wireless networking works. Resume from
suspend is still problematic, but that's something else. The bcm43xx driver in
this kernel functions for me.
Comment 7 John W. Linville 2006-08-01 14:44:26 EDT
I would expect the standard fedora kernels to work once they are based upon 
2.6.17.  I'm going to close this as UPSTREAM -- please reopen if the issues 
remains after fedora gets to 2.6.17.
Comment 8 Dave Jones 2006-08-01 21:48:52 EDT
umm, the standard Fedora kernels have been based on 2.6.17 for quite a few weeks
now.  I assume you meant .18 ?
Comment 9 John W. Linville 2006-08-02 11:17:40 EDT
Yes, 2.6.18 -- sorry for the confusion!

Note You need to log in before you can comment on or make changes to this bug.