Bug 193101 - as segfault. g77: Internal error: Segmentation fault (program as)
as segfault. g77: Internal error: Segmentation fault (program as)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 06:15 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 12:42:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed code that triggers the issue (8.44 KB, text/plain)
2006-05-25 06:15 EDT, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2006-05-25 06:15:07 EDT
Description of problem:
I cannot reduce the issue as I don't run rawhide and this issue pops
in rawhide. During a mock build using g77 -O3, the following error is
encountered:
g77: Internal error: Segmentation fault (program as)

The build log is at
http://buildsys.fedoraproject.org/logs/fedora-development-extras/9922-cernlib-2005-21.fc6/i386/build.log

I believe the error doesn't come from g77 but from something that
changed in rawhide. It may not be the case however.

the g77 options are:
g77 -g -c -O3 -fno-strength-reduce -funroll-loops -fno-automatic
-fno-second-underscore -fugly-complex

I attach the source code generated by g77 -E that triggers the 
segfault.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-05-25 06:15:07 EDT
Created attachment 129977 [details]
preprocessed code that triggers the issue
Comment 2 Jakub Jelinek 2006-05-26 09:52:09 EDT
Can't reproduce this on updated FC5, it assembles just fine.
Can you reproduceably get the same error always on the same file same error?
If you build with additional -save-temps, does it segfault too?
Comment 3 Patrice Dumas 2006-05-26 12:38:50 EDT
The error showed up in devel only. But I couldn't reproduce: 
the cernlib build I launched today succeded.
I let you close the bug the way you prefer...

Note You need to log in before you can comment on or make changes to this bug.