Bug 193111 - repo-rss should not generate a <body> entry
repo-rss should not generate a <body> entry
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 07:16 EDT by Aurelien Bompard
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 09:33:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add formating for description, get rid of the body tag (1.20 KB, patch)
2006-05-25 07:16 EDT, Aurelien Bompard
no flags Details | Diff
add a better formating for description, get rid of the body tag (1.22 KB, patch)
2006-05-25 12:54 EDT, Aurelien Bompard
no flags Details | Diff

  None (edit)
Description Aurelien Bompard 2006-05-25 07:16:21 EDT
Description of problem:
For each item in the rss feed, repo-rss generates two descriptions: one enclosed
in the description tag, one in the <body> tag.
I can't find the <body> tag in the rss spec, and it confuses my agregator: it
uses the contents of this tag, and strips out the html formatting. On the
contrary, if I remove the <body> element, <description> is picked up, with the
html tags properly escaped, and it shows just fine in the agregator.

I think it's not just my agregator, because if I try to validate a feed with
http://feedvalidator.org, a warning is issued about the body tag.

In addition, the description could use some formating. I'll attach a patch about
that.

Version-Release number of selected component (if applicable):
yum-utils-0.6-2.fc5
Comment 1 Aurelien Bompard 2006-05-25 07:16:21 EDT
Created attachment 129978 [details]
add formating for description, get rid of the body tag
Comment 2 Aurelien Bompard 2006-05-25 12:54:56 EDT
Created attachment 129998 [details]
add a better formating for description, get rid of the body tag

This patch also turns "\n" into "<br />" in the description, since it's HTML
now. This way the bullet lists turn out fine.
Comment 3 Tim Lauridsen 2007-02-14 09:33:33 EST
I have added the patch to upstream CVS, it will be available in next yum-utils
release. 

Note You need to log in before you can comment on or make changes to this bug.