Bug 193211 - Soundcard detection on HP dc7600
Soundcard detection on HP dc7600
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 00:12 EDT by paulp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 02:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output log file produced by system-config-soundcard (7.73 KB, text/plain)
2006-05-26 00:12 EDT, paulp
no flags Details
Output from running the commands on stransky alsa support page (6.32 KB, text/plain)
2006-07-05 17:10 EDT, paulp
no flags Details

  None (edit)
Description paulp 2006-05-26 00:12:41 EDT
Description of problem:
Fedora Core 5 is not properly configuring my soundcard. I have a new HP Small
Form Factor Desktop (dc7600) which uses the Intel 945G motherboard with
integrated Realtek ALC260 sound chip.
Running Sytem -> Administration -> Soundcard Detection, brings up the Audio
Devices screen. This shows:
Vendor: Intel
Model: Corporation 82801G (IHC7 Family) High Definition Audio Controller
Module: snd-hda-intel
Default PCM device: ALC260 Analog

Version-Release number of selected component (if applicable):
1.2.16-2

How reproducible:
Very

Steps to Reproduce:
1. system-config-soundcard (or using grapgical menus as above)
2.
3.
  
Actual results:
no sound heard

Expected results:
able to hear sample sound

Additional info:
Comment 1 paulp 2006-05-26 00:12:41 EDT
Created attachment 130011 [details]
Output log file produced by system-config-soundcard
Comment 2 Martin Stransky 2006-05-28 06:36:45 EDT
Could you please check this how-to?
http://people.redhat.com/stransky/alsa/
Comment 3 paulp 2006-07-05 17:08:40 EDT
Sorry for the delay in following this up.
I have run through your alsa how-to page and was unsuccessful.
I have attached an output file which indicates some problem encountered during
the 'make' command.
When I now run system-config-soundcard the details show the same vendor, model
and driver but there is no Default PCM Device....
Comment 4 paulp 2006-07-05 17:10:41 EDT
Created attachment 131963 [details]
Output from running the commands on stransky alsa support page
Comment 5 paulp 2006-07-13 22:22:56 EDT
I have since updated my kernel to 2.6.17-1.2145_FC5-i686 and updated all the
alsa packages to the latest stable versions found by yum (1.0.11rc4) and now get
the following error in make...

[snip]
/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.o
/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.c: In
function ‘tx_loop’:
/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.c:317:
error: ‘struct tty_struct’ has no member named ‘atomic_write’
/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.c:322:
error: ‘struct tty_struct’ has no member named ‘atomic_write’
/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.c:339:
error: ‘struct tty_struct’ has no member named ‘atomic_write’
make[4]: ***
[/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers/serialmidi.o]
Error 1
make[3]: *** [/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4/drivers]
Error 2
make[2]: *** [_module_/data/downloads/soundcard_driver/alsa-driver-1.0.11rc4]
Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.17-1.2145_FC5-i686'
make: *** [compile] Error 2


I am not sure what else to do - are there missing libraries/packages needed for
configure/make to compile a module for this kernel?
Comment 6 Martin Stransky 2006-08-04 16:15:19 EDT
okay, I updated my ALSA page so could you please check the latest ALSA driver
package from my site? (http://people.redhat.com/stransky/alsa/, package
alsa-driver-1.0.12rc1)
Comment 7 paulp 2006-08-07 15:51:30 EDT
Thanks Martin! That new alsa tar ball compiled a treat and worked first time!

Note You need to log in before you can comment on or make changes to this bug.