Bug 193249 - Eclipse + CDT early failure after startup, during C/C++ indexing
Eclipse + CDT early failure after startup, during C/C++ indexing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 11:37 EDT by Edward Hildum
Modified: 2008-02-12 15:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 15:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Hildum 2006-05-26 11:37:54 EDT
Description of problem:
I am working with a fresh install of Eclipse 3.1.2 and CDT from fedora core 5
RPMs, and with subclipse added using the standard update procedure.  This
installation worked for several hours without problems on 5/23, building a
moderately large C/C++ project and updating SVN repositories.  The following
day, after installing updates using yum, this installation fails after startup,
during the C/C++ indexing process with the following messages:

java.lang.ClassCastException:
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTQualifiedName cannot be cast
to org.eclipse.cdt.core.dom.ast.cpp.ICPPASTFunctionDeclarator
   at
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPFunctionTemplate.takesVarArgs
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.IndexVisitorUtil.getParameters
(cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.CPPGenerateIndexVisitor.processNameBinding
(cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.CPPGenerateIndexVisitor.processName
(cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.CPPGenerateIndexVisitor.visit
(cdtcore.jar.so)
   at org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTName.accept
(cdtparser.jar.so)
   at org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTQualifiedName.accept
(cdtparser.jar.so)
   at org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTDeclarator.accept
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTFunctionDefinition.accept
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTTemplateDeclaration.accept
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTTemplateDeclaration.accept
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTNamespaceDefinition.accept
(cdtparser.jar.so)
   at org.eclipse.cdt.internal.core.dom.parser.cpp.CPPASTTranslationUnit.accept
(cdtparser.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.DOMSourceIndexerRunner.indexFile
(cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.AbstractIndexerRunner.index
(cdtcore.jar.so)
   at org.eclipse.cdt.internal.core.index.cindexstorage.Index.add (cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.DOMAddCompilationUnitToIndex.indexDocument
(cdtcore.jar.so)
   at
org.eclipse.cdt.internal.core.index.domsourceindexer.DOMAddFileToIndex.execute
(cdtcore.jar.so)
   at org.eclipse.cdt.internal.core.search.processing.JobManager.run
(cdtcore.jar.so)
   at java.lang.Thread.run (libgcj.so.7)

The following updates were installed with yum on 5/23:

May 23 08:51:28 Updated: tzdata.noarch 2006g-1.fc5
May 23 08:51:56 Updated: glibc-common.i386 2.4-8
May 23 08:52:40 Updated: glibc.i686 2.4-8
May 23 08:52:41 Updated: cups-libs.i386 1:1.2.0-1.1
May 23 08:52:47 Updated: sane-backends.i386 1.0.17-5.fc5.9
May 23 08:52:52 Updated: policycoreutils.i386 1.30.8-1.fc5
May 23 08:52:58 Updated: cups.i386 1:1.2.0-1.1
May 23 08:54:07 Updated: kdelibs.i386 6:3.5.2-0.2.fc5
May 23 08:54:20 Updated: wine.i386 0.9.13-2.fc5
May 23 08:54:22 Updated: libsane-hpaio.i386 0.9.11-1.1
May 23 08:54:26 Updated: avahi.i386 0.6.9-9.FC5
May 23 08:55:07 Updated: kdepim.i386 6:3.5.2-0.4.fc5
May 23 08:55:11 Updated: kdelibs-devel.i386 6:3.5.2-0.2.fc5
May 23 08:55:40 Updated: system-config-printer.i386 0.6.151.7-1
May 23 08:55:41 Updated: librsvg2.i386 2.14.4-1.fc5.1
May 23 08:55:47 Updated: glibc-headers.i386 2.4-8
May 23 08:55:48 Updated: libstdc++so7.i386 4.2.0-0.3.20060428.fc5.1
May 23 08:55:49 Updated: scim-libs.i386 1.4.4-9.2.fc5
May 23 08:55:54 Updated: selinux-policy.noarch 2.2.38-1.fc5
May 23 08:55:55 Updated: libraw1394.i386 1.2.1-1.fc5
May 23 08:56:07 Updated: dia.i386 1:0.95-2.fc5
May 23 08:56:09 Updated: lftp.i386 3.4.6-1.FC5
May 23 08:56:11 Updated: nmap.i386 2:4.03-0.fc5
May 23 08:56:13 Updated: ntp.i386 4.2.0.a.20050816-11.FC5
May 23 08:56:14 Updated: nmap-frontend.i386 2:4.03-0.fc5
May 23 08:56:15 Updated: hpijs.i386 1:0.9.11-1.1
May 23 08:56:15 Updated: dosfstools.i386 2.11-5.FC5
May 23 08:56:17 Updated: sane-backends-devel.i386 1.0.17-5.fc5.9
May 23 08:56:37 Updated: selinux-policy-strict.noarch 2.2.38-1.fc5
May 23 08:56:55 Installed: kernel.i686 2.6.16-1.2122_FC5
May 23 08:56:56 Updated: librsvg2-devel.i386 2.14.4-1.fc5.1
May 23 08:57:02 Updated: firefox.i386 1.5.0.3-1.1.fc5
May 23 08:57:04 Updated: cups-devel.i386 1:1.2.0-1.1
May 23 08:57:06 Updated: kdepim-devel.i386 6:3.5.2-0.4.fc5
May 23 08:57:26 Updated: libbeagle.i386 0.2.6-1.fc5.1
May 23 08:57:26 Updated: avahi-glib.i386 0.6.9-9.FC5
May 23 08:57:28 Updated: scim-devel.i386 1.4.4-9.2.fc5
May 23 08:57:31 Updated: wine-devel.i386 0.9.13-2.fc5
May 23 08:57:33 Updated: hal-cups-utils.i386 0.5.5-1.2.fc5.2
May 23 08:57:35 Updated: psmisc.i386 22.2-1.1
May 23 08:57:36 Updated: nscd.i386 2.4-8
May 23 08:57:41 Updated: glibc-devel.i386 2.4-8
May 23 08:57:42 Updated: vnc-server.i386 4.1.1-38.fc5
May 23 09:01:54 Installed: fedora-rpmdevtools.noarch 1.6-1.fc5


Version-Release number of selected component (if applicable):


How reproducible:
Every eclipse start crashes.

Steps to Reproduce:
1. invoke eclipse via ./eclipse &
  
Actual results:
Crash

Expected results:
Eclipse runs and completes C/C++ indexing

Additional info:
A similar installation on FC5, but a different machine, does not show this
problem.  I will scrub the installation and reinstall to see if the problem is
fixed.
Comment 1 Andrew Overholt 2007-04-16 16:47:04 EDT
Man, it's been a long time since this was filed.  Can you still duplicate?  Jeff, have you seen anything like this or have any idea how to fix?
Comment 2 Jeff Johnston 2007-04-16 18:34:42 EDT
I haven't seen this but I don't have any complex C++ projects I am indexing. 
The indexer for this release has been deemed buggy and has been completely
rewritten for CDT 4.0.  Any fixes will not be back-ported.  Edward, are you able
to try out the new CDT 4.0 M6 build?
Comment 3 Edward Hildum 2007-04-17 21:05:18 EDT
I am currently out of the office on vacation.  I have not had this problem
recently, but I routinely disable indexing for large projects.  When I get back
in the office, I will enable indexing for a big project and see how it goes.  I
am now using an up-to-date FC6 installation.
Comment 4 Jeff Johnston 2008-02-12 15:44:45 EST
I am closing this bug with NEXTRELEASE (see comment 2).  If there are problems
with the new 4.0.1 indexer on F8, then please submit a new bug.

Note You need to log in before you can comment on or make changes to this bug.