Bug 193264 - Software Updater.
Software Updater.
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 13:34 EDT by John Ward
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 13:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This error occurred when running a software update. (1.17 KB, application/octet-stream)
2006-05-26 13:34 EDT, John Ward
no flags Details
Software Updater / Yum Error (1.24 KB, text/plain)
2006-07-07 13:16 EDT, bill
no flags Details

  None (edit)
Description John Ward 2006-05-26 13:34:40 EDT
Description of problem:
Problem appears when running a software update.


Version-Release number of selected component (if applicable):


How reproducible:
Problem occurrs everytime the Software Updater is run.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ward 2006-05-26 13:34:40 EDT
Created attachment 130036 [details]
This error occurred when running a software update.
Comment 2 bill 2006-07-07 13:16:14 EDT
Created attachment 132068 [details]
Software Updater / Yum Error
Comment 3 Roman Lazarev 2006-07-27 08:48:28 EDT
id=130036

Component: Software Installer
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 229, in ?
    main()
  File "/usr/sbin/system-install-packages", line 224, in main
    pkginst = SinglePackageInstaller()
  File "/usr/sbin/system-install-packages", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
    self.doPluginSetup(types=(yum.plugins.TYPE_CORE))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in
doPluginSetup
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__
    self.run('config')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb7a0d32c>
parser: None

id=132068

Component: Software Installer
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 229, in ?
    main()
  File "/usr/sbin/system-install-packages", line 224, in main
    pkginst = SinglePackageInstaller()
  File "/usr/sbin/system-install-packages", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
    self.doPluginSetup(types=(yum.plugins.TYPE_CORE))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in
doPluginSetup
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__
    self.run('config')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb7a0d32c>
parser: None
Comment 4 John Thacker 2006-10-29 08:29:12 EST
These are all bugs in pirut/pup, not up2date.  Pirut replaced up2date in FC5 and
forward.  Reassigning component.
Comment 5 Jeremy Katz 2006-10-30 13:40:30 EST

*** This bug has been marked as a duplicate of 191630 ***

*** This bug has been marked as a duplicate of 191630 ***

Note You need to log in before you can comment on or make changes to this bug.