Bug 193341 - logvol kickstart directive no longer supported?!?
logvol kickstart directive no longer supported?!?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-27 14:02 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 15:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-05-27 14:02:18 EDT
Description of problem:
I tried a kickstart install of rawhide yesterday, and it failed miserably.  VT3
had warnings about unsupported logvol directives, that FC5 and before accepted
just fine, so we seem to have some kind of regression here.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.21-1

How reproducible:
Every time

Steps to Reproduce:
1.Try a kickstart install with a kickstart file containing logvol directives
  
Actual results:
Anaconda says it is ignoring them, and eventually aborts the install

Expected results:
Successful install

Additional info:
Comment 1 Chris Lumens 2006-06-02 13:14:32 EDT
Works fine for me on anaconda-11.1.0.23.  Perhaps you just picked a day where
anaconda and pykickstart were out of sync to install.
Comment 2 Alexandre Oliva 2006-08-04 12:22:51 EDT
If it worked fine then, it was broken again :-(

Here's my logvol entries.  Anaconda still prints the warning that it does not
recognize the directive, and then it complains that I didn't define a root
device.  This is a non-interactive kickstart install, if it makes any difference.

clearpart --none
volgroup all --noformat
logvol / --useexisting --fstype ext3 --name=test --vgname=all --fsoptions="noati
me"
logvol swap --useexisting --fstype swap --name=swap --vgname=all
part swap --onpart hda2
logvol /l --noformat --fstype ext3 --name=l --vgname=all --fsoptions="noatime"
raid /boot --useexisting --fstype ext3 --device=md6 --fsoptions="noatime"
raid /l/root/boot --noformat --fstype ext3 --device=md5 --fsoptions="noatime"
logvol /l/root --noformat --fstype ext3 --name=stable --vgname=all --fsoptions="
noatime"
Comment 3 Chris Lumens 2006-08-07 15:39:41 EDT
The message about not being supported is just sloppy error handling covering up
the real cause.  Fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.