Bug 193344 - k3b - no write/erase/format - "cannot gain /dev/hdc exclusively"
k3b - no write/erase/format - "cannot gain /dev/hdc exclusively"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-27 16:04 EDT by Paul
Modified: 2008-05-06 11:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
k3b debugging output (2.22 KB, text/plain)
2006-05-27 16:04 EDT, Paul
no flags Details
k3b debug report (4.45 KB, text/plain)
2006-05-27 16:39 EDT, Paul
no flags Details
k3b bug report (4.45 KB, text/plain)
2006-05-27 16:40 EDT, Paul
no flags Details

  None (edit)
Description Paul 2006-05-27 16:04:53 EDT
Description of problem:
Cannot write to dvd/cd - ALL writing apps begin to write then almost immediately
end the writing with no disk activity.

Version-Release number of selected component (if applicable):
K3b Version: 0.12.14
KDE Version: 3.5.2-0.2.fc5 Red Hat
QT Version:  3.3.5
Kernel:      2.6.16-1.2122_FC5

How reproducible:
Always

Steps to Reproduce:
  
Actual results:
cd/DVD disk unwritten to but ruined by something
Rewriteable disks cannot be erased or formatted

Expected results:
Should write to cd/dvd effortlessly

Additional info:
I have tried all my cd/DVD writing tools and they all seem to have the same
result from the problem. K3B may only be the symptom and not the cause.

Hope this helps.
Comment 1 Paul 2006-05-27 16:04:53 EDT
Created attachment 130069 [details]
k3b debugging output
Comment 2 Paul 2006-05-27 16:39:53 EDT
Created attachment 130086 [details]
k3b debug report
Comment 3 Paul 2006-05-27 16:40:35 EDT
Created attachment 130087 [details]
k3b bug report
Comment 4 Paul 2006-05-27 16:45:05 EDT
I lost some text when I added the second attachment. It looks like a bug in
bugzilla.

I will try again. My outside searches suggest that this bug has something to do
with the automount feature. I may be mistaken.

I added "/dev/cdrom /media/cdrecorder auto noauto,owner,rw 0 0" to the fstab and
it generated attachment #2 [details].

I added "/dev/hdc /media/cdrecorder auto noauto,owner,rw 0 0" to the fstab and
it generated attachment #3 [details].

#2 and #3 appear different.

Hope this helps.

Comment 5 Rex Dieter 2006-05-27 18:41:20 EDT
Reassigning to Fedora Core/k3b.
Comment 6 Rex Dieter 2006-05-27 18:41:49 EDT
Reassigning to Fedora Core/k3b.
Comment 7 Harald Hoyer 2006-05-29 08:25:24 EDT
First attachment: Sense Key: 0x3 Medium Error, Segment 0
Second attachment: Sense Key: 0x4 Hardware Error, Segment 0
Third attachement: disk may be mounted or used by another applicationI added 

Adding s.th. to fstab has no effect on CD burning.
I can burn fine with my 'HL-DT-ST' 'DVDRRW GWA-4161B' '1.15'
Comment 8 Paul 2006-05-29 09:30:44 EDT
Good Day . . .

Thank You for the reply.

While checking your bugzilla returned no hits on this problem, checking the
redhat forum yielded about 20 - 30 hits on the search item - "k3b exclusively"

The problem seems to be universal with no real suggestions for a bug solution.

For your attention.

Hope this helps.
Comment 9 Harald Hoyer 2006-05-29 09:39:16 EDT
Well, cdrecord cannot tell, which application is blocking the device.
Comment 10 Paul 2006-05-29 11:32:34 EDT
Good Day . . .

Fiddling around with different types of cd/dvds and umount and mount leads me to
believe that possibly the automount feature may have a bearing on the bug.

Here are some more facts:

- I can insert a cd-rw and umount it prior to k3b and I can erase the disk.
- I cannot write to the disk after because k3b auto ejects the disk after the
erase and subsequently the cd-rw is remounted.
- I cannot umount a blank disk because the menu from secondary clicking on the
icon does not include an unmount option. If it is mounted then nothing shows
this from my limited technical knowledge.

I searched unsuccessfully for instructions about how to disable automount on the
cd/dvd. Maybe RedHat can point me in the right direction and I can help debug
this issue?

Hope this helps.
Comment 11 Harald Hoyer 2006-05-29 11:54:06 EDT
KDE or Gnome?
Comment 12 Paul 2006-05-29 14:19:14 EDT
Good Day . . .

KDE
Comment 13 Harald Hoyer 2006-05-30 05:38:40 EDT
do as root:
# rpm -e autorun
and as a user (also in KDE):
$ gnome-volume-properties
Comment 14 Paul 2006-05-30 12:17:33 EDT
Good Day . . .

Thank You for the reply.

All bad news.

- I erased autorun and started gnome-volume-properties as user
- Received error message about invalid MIT-MAGIC-COOKIE-1
- Searched - common problem across distros
- Something to do with system access (input/output error ?)
- tried k3b - same symptoms
- erased autofs since this has something to do with automount
- tried k3b - same symptons
- installed autorun & autofs
- tried k3b - something different
  same non writing but no closing error messages
  message in info box says "input/output error"
  k3b advises "Success" on closing write process
- started gnome-volume-properties
  no error message - gui appears
- removed all removeable media from automount
- tried k3b
  same non-writing
  same "Success" message on closing write process
- tried nautilus
  same non-writing
  same "Success" message on closing write process

I need the dvd so I will keep looking for a solution.
Hope your keep helping.
So far, I have lost 17 dvds - k3b will not allow simulate on dvds.

Hope this helps.

  
Comment 15 Harald Hoyer 2006-05-31 05:51:32 EDT
Try to use growisofs from dvd+rw-tools. k3b _should_ automatically use
growisofs, if it is installed. growisofs normally burns DVD just fine, besides
of some Plextor drives.

I will also release a new cdrecord version, which hopefully fixes some bugs.
Comment 16 Paul 2006-05-31 22:03:08 EDT
Thank You for the reply.

Your suggestion generated essentially the same error.

I used "growisofs -Z /dev/hdc -R -J /home/. . ."
The following errors appeared:
  :-[ WRITE@LBA=120h failed with SK=4h/ASC=08h/ACQ=03h]: Input/output error
  builtin_dd: 288*2KB out @ average 0.0x1385KBps
  :-( write failed: Input/Output error

Hope this helps.

ps: I am now up to 22 dvd coasters. May I suggest that simulation for a dvd be
included at the earliest opportunity. :-)

Comment 17 Harald Hoyer 2006-06-01 07:20:22 EDT
here is a new cdrecord you can try.. you may try "-dummy", which works, if your
drive supports it.
http://www.redhat.com/archives/fedora-test-list/2006-May/msg00368.html
Comment 18 Paul 2006-06-01 18:12:09 EDT
Good Day . . .

Thank You for the reply.

I regret to inform you that after the update was installed k3b still exhibited
the same symptoms - no writing followed by a successful message.

My last successful DVD write was a backup data disk on 6 April 2006. I have
tried to reverse all the personal changes that I have made to KDE and GDMSetup
but the bug is still present. I can still watch movies and copy files from the
DVD. Strange problem.

I'll put one of my earlier distros on a removeable hard drive and see if the
problem is present.

Hope this helps.
Comment 19 Paul 2006-06-01 21:11:58 EDT
Good Day . . .

Good news and bad news. I never discounted that the drive has become worn out so
I took out a Sony dru-810a from my other machine and replaced the lg. The Sony
drive works! I successfully made a file backup on DVD.

To be sure about the worn out aspect I installed the lg into the Sony slot on my
other Suse 10.0 machine. Bad news is that it works! I used my last DVD and it
came out good.

I realise that you know far more about this subject than I do but I did locate
two online messages on this subject. The first contains an awful lot of
technical information and appears to be a complete duplicate of my bug.
Unfortunately no solution is found.

http://lists.debian.org/debian-amd64/2006/03/msg00169.html
http://k3b.plainblack.com/message-board/problem-with-dma

Hope this helps.


Comment 21 Paul 2006-06-07 15:30:41 EDT
Good Day . . .

Thank You for the information.

The link the above link directed me to was for a file titled "cdrtools." The
next link to i386/ did not contain a file entitled "cdrtools" but it did contain
a file titled "cdrecord" with the same version and revision numbers as cdrtools.

Are we missing a file or is the name wrong?

Hope this helps.
Comment 23 Paul 2006-06-15 11:11:40 EDT
Good Day . . .

Thanks for the reply. Sorry for the delay but I have been away.

The point that I was making was that the link's file's title was 'cdrtools' but
the revision number belonged to 'cdrecord.' I downloaded that file.

It appears to work. When I exchanged the drives. The old drive did not work at
all on this machine. The new drive was recording backups to CD but would not
close the CD making it unreadable. A DVD backup worked well.

The new download seems to have solved the CD recording issue. Unfortunately it
was my last CD disc. I have about 25 DVD and CD coasters. I live in the country
so getting a new supply will have to wait for the 23rd of June and a special at
one of the electronics stores.

Thank You for the help. I really appreciate it.

If I can do anything to assist let me know.

Comment 24 Bug Zapper 2008-04-03 22:59:04 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 25 Bug Zapper 2008-05-06 11:57:12 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.