Bug 193441 - internal compiler error: in get_indirect_ref_operands, at tree-ssa-operands.c:1523
internal compiler error: in get_indirect_ref_operands, at tree-ssa-operands.c...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-28 14:38 EDT by Andrew Ziem
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-29 06:01:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (3.50 MB, text/plain)
2006-05-28 14:38 EDT, Andrew Ziem
no flags Details

  None (edit)
Description Andrew Ziem 2006-05-28 14:38:51 EDT
Description of problem:
When compiling, I get this error:
 duckmatic.cpp: In member function 'void studio::Duckmatic::add_duck(const
etl::handle<studio::Duck>&)':
 duckmatic.cpp:545: internal compiler error: in get_indirect_ref_operands, at
tree-ssa-operands.c:1523
 Please submit a full bug report,
 with preprocessed source if appropriate.
 See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
 Preprocessed source stored into /tmp/ccgf8vLm.out file, please attach this to
your bugreport.


Version-Release number of selected component (if applicable):
gcc-4.1.1-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh
http://repo.nrpms.net/synfigstudio/0.61.04/SRPMS/synfigstudio-0.61.04-1.1.fc4.nr.src.rpm
2. rpmbuild ~/rpmbuild/SPECS/synfigstudio.spec
  
Actual results:
The error message above.

Expected results:
No error.

Additional info:
To satisfy build dependencies, install the two below RPMs.  Also, in synfig.spec
you may need to change an item in BuildRequires from "libxml++2-devel" to
"libxml++-devel".
http://repo.nrpms.net/etl/0.04.07/SRPMS/etl-0.04.07-1.1.fc4.nr.src.rpm
http://repo.nrpms.net/synfig/0.61.04/SRPMS/synfig-0.61.04-2.1.fc4.nr.src.rpm
Comment 1 Andrew Ziem 2006-05-28 14:38:52 EDT
Created attachment 130159 [details]
Preprocessed source
Comment 2 Jakub Jelinek 2006-05-29 06:01:43 EDT
Sorry, can't reproduce:
rpm -q gcc-c++; g++ -m32 -march=i386 -mtune=generic -O2 -Wall -Wno-deprecated \
-W -Wno-unused-parameter -fexceptions -fstack-protector \
-fasynchronous-unwind-tables -ffast-math --param ssp-buffer-size=4 \
-c 193441.ii; echo $?
gcc-c++-4.1.1-1.fc5
0

Note You need to log in before you can comment on or make changes to this bug.