Bug 193453 - postgresql-server doesn't link its libraries
Summary: postgresql-server doesn't link its libraries
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-29 02:22 UTC by Zenon Panoussis
Modified: 2013-07-03 03:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-29 14:16:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zenon Panoussis 2006-05-29 02:22:54 UTC
Description of problem:
postgresql-server puts a bunch of files in /usr/lib/pgsql. 
Its %post scrptlet runs ldconfig, but ldconfig ignores the 
directory where the new libs were just installed.

Version-Release number of selected component (if applicable):
7.4.13-2.RHEL4.1

Additional info:
Something like this would probably fix it:
--- postgresql.spec.orig        2006-05-28 21:21:45.000000000 -0500
+++ postgresql.spec     2006-05-28 21:24:20.000000000 -0500
@@ -569,6 +569,7 @@

 %post server
 chkconfig --add postgresql
+echo "%{_libdir}/pgsql" >/etc/ld.so.conf.d/pgsql-%{_arch}.conf
 /sbin/ldconfig

 %preun server
@@ -578,6 +579,7 @@
 fi

 %postun server
+rm -f /etc/ld.so.conf.d/pgsql-%{_arch}.conf
 /sbin/ldconfig
 if [ $1 -ge 1 ] ; then
        /sbin/service postgresql condrestart >/dev/null 2>&1 || :

Comment 1 Tom Lane 2006-05-29 03:24:18 UTC
I do not see the problem here.  All those .so files are intended to be loaded via explicit dlopen; there is no 
need for ldconfig to process them.  What specific problem are you having that makes you think they need 
to be included in ldconfig's list?

Comment 2 Zenon Panoussis 2006-05-29 05:29:11 UTC
Aha, in that case there's no bug. I was having a problem with
/usr/lib/pgsql/postgis.so from the non-RH package with the same name, noticed
there was no ldconfig pointer to the directory, and assumed postgres should have
made one irrespective of postgis. Sorry for the false alarm.

Comment 3 Tom Lane 2006-05-29 14:16:07 UTC
OK, closing as NOTABUG then.


Note You need to log in before you can comment on or make changes to this bug.