Bug 193472 - /usr/sbin/module_upgrade - segmentation fault
/usr/sbin/module_upgrade - segmentation fault
Status: CLOSED DUPLICATE of bug 190938
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 08:30 EDT by Tim Fletcher
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 02:26:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace (1.20 KB, text/plain)
2006-05-29 08:30 EDT, Tim Fletcher
no flags Details
strace output (48.53 KB, text/plain)
2006-05-29 08:32 EDT, Tim Fletcher
no flags Details

  None (edit)
Description Tim Fletcher 2006-05-29 08:30:36 EDT
Description of problem:

When running /usr/sbin/module_upgrade during a kernel upgrade a seg fault occurs

This fault only occurs on machines upgraded from older releases of fedora, I
have run rpm -V on kudzu, initscripts and glibc. I think it might be releated to
bug 179000 but don't know.

Version-Release number of selected component (if applicable):

kudzu-1.2.34.3-1
kernel-smp-2.6.16-1.2096_FC5
kernel-smp-2.6.16-1.2122_FC5
glibc-2.4-8

How reproducible:

Always, but only on a machine has been upgraded from older Fedora core releases

Steps to Reproduce:
1. install fedora core 1
2. Upgrade to core 5 (via cd)
3. run /usr/sbin/module_upgrade
  
Actual results:

[root@baneberry ~]# module_upgrade 2.6.16-1.2122_FC5smp
Segmentation fault

Expected results:

No seg fault

Additional info:

I haev attached the output of gdb and strace
Comment 1 Tim Fletcher 2006-05-29 08:30:36 EDT
Created attachment 130187 [details]
gdb backtrace
Comment 2 Tim Fletcher 2006-05-29 08:32:23 EDT
Created attachment 130188 [details]
strace output
Comment 3 Bill Nottingham 2006-05-30 02:26:13 EDT

*** This bug has been marked as a duplicate of 190938 ***

Note You need to log in before you can comment on or make changes to this bug.