Bug 193482 - xmms i386 build hangs in buildsys
xmms i386 build hangs in buildsys
Status: CLOSED ERRATA
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 11:20 EDT by Ville Skyttä
Modified: 2007-04-18 13:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 14:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff to check where building of xmms hangs (1.89 KB, patch)
2006-05-30 08:40 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2006-05-29 11:20:46 EDT
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00874.html
http://buildsys.fedoraproject.org/build-status/job.psp?uid=9945

Something makes the xmms build hang in the i386 devel builder, x86_64 and ppc
are fine.  I cannot reproduce that locally in mach or mock.  I'm intentionally
leaving the currently stuck job there (currently in progress for 9 hours) so
someone can possibly debug it.

See also bug 193460
Comment 1 Mamoru TASAKA 2006-05-29 12:10:29 EDT
In fact, except for arts-devel umask problem, I can rebuild xmms by myself.
For now, I have no idea for xmms building hang.
Comment 2 Ville Skyttä 2006-05-29 13:56:11 EDT
Looks like this is indeed a problem with i386/devel only, FC-5 built fine.
http://buildsys.fedoraproject.org/build-status/job.psp?uid=10048
Comment 3 Mamoru TASAKA 2006-05-30 08:40:43 EDT
Created attachment 130224 [details]
Diff to check where building of xmms hangs

Ville, the diff file I attached is VERY UGLY, but I think this is useful for
detecting where buildsys hangs for rebuilding xmms.
Comment 4 Jeremy Katz 2006-06-04 14:50:08 EDT
Ville -- is this still happening?  (of course, now the devel tree is busted today)
Comment 5 Dan Williams 2006-06-05 07:48:00 EDT
Some more data points from debugging this last week:

1) Only happens building i386 jobs on an x86_64 build host
2) pstree output shows the last child process is 'sed', spawned by libtool.  No
idea why sed is hanging
3) strace on the sed process shows its sitting in futex lock or whatever that is
4) gdb is useless here for backtraces; apparently after FC3/RHEL4 gdb got a
better ability to show symbols for 32-bit binaries with a 64-bit gdb, but we're
screwed right now
5) pstack shows sed is sitting in the vDSO somewhere around 0xffffe405 (iirc)

So either I need to start building custom gdbs, or I need to figure out some
other way to determine WTF the hung processes are doing.  Blocked pipes?  I have
no idea.


Comment 6 Jeremy Katz 2006-06-05 08:23:43 EDT
Hangs in futex tend to be "fun with the kernel" -- unfortunately, I've never
gotten a better way of really debugging them :-/

Have we tried rebooting the builder?  
Comment 7 Dan Williams 2006-06-05 09:47:42 EDT
Not recently.  Want to try it on hammer1?
Comment 8 Jeremy Katz 2006-06-05 13:32:37 EDT
It's been kicked
Comment 9 Ville Skyttä 2006-06-18 13:05:47 EDT
Seeing that the kerry package which was reported to have the same problem was
built successfully today made me try it again, but unfortunately the xmms build
still hangs (job 9945).  Cc'ing Warren, IIRC you were trying to debug this some
time ago.
Comment 10 Ville Skyttä 2006-06-21 14:44:08 EDT
The kernel upgrades seem to have fixed this, thanks.

Note You need to log in before you can comment on or make changes to this bug.