Bug 193494 - fc5 breaks WordPerfect 8
fc5 breaks WordPerfect 8
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 16:12 EDT by james
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 13:21:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2006-05-29 16:12:06 EDT
Description of problem:
after installing the compatability packages - ld.so-1.9.9-11.i686.rpm and 
libc-5.4.46-4.i686.rpm - Word Perfect 8 seg faults in FC5.  

Version-Release number of selected component (if applicable):
I don't know if this is a glibc problem or not.  Maybe you know where to move this?

  
Actual results:
strace leading to seg fault was:

 access("/usr/X11R6/lib/X11/icons/50_foreground", R_OK) = -1 ENOENT (No such
file or directory)
 access("/usr/X11R6/include/X11/icons/50_foreground", R_OK) = -1 ENOENT (No such
file or directory)
 open("/usr/X11R6/lib/X11/locale/locale.alias", O_RDONLY) = -1 ENOENT (No such
file or directory)
 open("/usr/X11R6/lib/X11/locale/locale.dir", O_RDONLY) = -1 ENOENT (No such
file or directory)
 open("/usr/X11R6/lib/X11/locale/locale.alias", O_RDONLY) = -1 ENOENT (No such
file or directory)
 open("/usr/X11R6/lib/X11/locale/locale.dir", O_RDONLY) = -1 ENOENT (No such
file or directory)
 --- SIGSEGV (Segmentation fault) @ 0 (0) ---

wpexc still runs, but everything else in wp seems to also segfault.
selinux is permissive. kernel is 2.6.16-1.2122_FC5 on an athlon.

Additional info:
Word Perfect still works fine in FC4, and lots of businesses still use Word
Perfect 8, so this should be fixed.
Comment 1 Jakub Jelinek 2006-05-30 04:33:25 EDT
This has nothing to do with glibc, as WP8 clearly uses libc5, it doesn't
use any of the glibc libraries.
From the strace you cited it more looks like WP8 is incapable of grokking the
xorg-x11 fs layout reshuffling (e.g. locale.alias is now in
/usr/share/X11/locale/locale.alias etc.).
Comment 2 Mike A. Harris 2006-05-30 13:21:10 EDT
(In reply to comment #1)
> From the strace you cited it more looks like WP8 is incapable of grokking the
> xorg-x11 fs layout reshuffling (e.g. locale.alias is now in
> /usr/share/X11/locale/locale.alias etc.).

Word Perfect 8 appears to be hard coding the path to things on the
filesystem, and crashing if it does not find what it is looking for
there.  This is a bug in Word Perfect not being compatible with
X11R7.

I'm not sure if Corel supports WP8 on Linux or not, so you may
need to work around it using symbolic links, a chroot jail, Xen,
VMware, or some other workaround.

Setting status to "CANTFIX" as this is a bug in Word Perfect not
Fedora Core.
Comment 3 james 2006-06-01 04:06:59 EDT
Thanks Jakub and Mike - good call!  I tried the link
 ln -s /usr/share/X11 /usr/X11R6/lib/X11
and that seems to have avoided the segfault.  Now I get a pixmap error:

 An unrecoverable X Window server error has occurred.
 Your WordPerfect documents have been backed up in your backup directory.
 X Error of failed request:  BadPixmap (invalid Pixmap parameter)
   Major opcode of failed request:  54 (X_FreePixmap)
   Resource id in failed request:  0x0
   Serial number of failed request:  2732
   Current serial number in output stream:  2753

Can you suggest what to do to workaround that?

Note You need to log in before you can comment on or make changes to this bug.