Bug 193498 - perl-Image-Info and reduced build root
perl-Image-Info and reduced build root
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Image-Info (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jose Pedro Oliveira
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 18:10 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 13:45:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log from Tibbs with "TEST_VERBOSE=1" (10.00 KB, text/plain)
2006-06-22 14:05 EDT, Jose Pedro Oliveira
no flags Details

  None (edit)
Description Jose Pedro Oliveira 2006-05-29 18:10:23 EDT
Fails to build in the reduced build root.
----------
...
t/string.......
#   Failed test 'no error'
#   in t/string.t at line 63.
#          got: 'XMLin() requires either XML::SAX or XML::Parser at
../lib/Image/Info/SVG.pm line 42
# '
#     expected: undef
# Looks like you failed 1 test of 22.
dubious
	Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 15
	Failed 1/22 tests, 95.45% okay
...
----------

perl-Image-Info build log:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-extras/i386/perl-Image-Info-1.21-2.fc6.src.rpm/result/build.log

May be related to the perl-XML-Simple failure

perl-XML-Simple build log:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/perl-XML-Simple-2.14-2.1.src.rpm/result/build.log
Comment 1 Jose Pedro Oliveira 2006-06-04 13:08:19 EDT
The problem is in the perl-XML-Simple package (missing requirement).

More information available in 
perl-XML-Simple: must require perl-XML-Parser and/or perl-XML-SAX
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193985
Comment 2 Jose Pedro Oliveira 2006-06-07 18:23:01 EDT
perl-XML-Simple has been updated. Should appear shortly in the mirrors. 
Comment 3 Jose Pedro Oliveira 2006-06-15 11:16:30 EDT
Fedora Core 5 Update: perl-XML-Simple-2.14-4.fc5
https://www.redhat.com/archives/fedora-package-announce/2006-June/msg00082.html

---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2006-672
2006-06-12
---------------------------------------------------------------------

Product     : Fedora Core 5
Name        : perl-XML-Simple
Version     : 2.14
Release     : 4.fc5
Summary     : Easy API to maintain XML in Perl
Description :
The XML::Simple module provides a simple API layer on top of an
underlying XML parsing module (either XML::Parser or one of the SAX2
parser modules).

---------------------------------------------------------------------

* Wed Jun  7 2006 Jason Vas Dias <jvdias redhat com> - 2.14-4
- fix bug 191911: make test fails when default Parser is XML::SAX::PurePerl -
                  succeeds when default Parser is XML::LibXML::SAX -
	          +BuildRequires: perl(XML::LibXML) perl(XML::LibXML::Common)
* Wed Jun  7 2006 Matthias Clasen <mclasen redhat com> - 2.14-2.2
- Require perl-XML-Parser (#193985)

---------------------------------------------------------------------
Comment 4 Jose Pedro Oliveira 2006-06-15 11:20:18 EDT
New problem in the FE-devel x86_64 build
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-extras/x86_64/perl-Image-Info-1.21-2.fc6.src.rpm/result/build.log

----------
t/string.......Use of uninitialized value in pack at ../lib/Image/Info/TIFF.pm
line 83.
Use of uninitialized value in pack at ../lib/Image/Info/TIFF.pm line 83.

#   Failed test 'no error'
#   in t/string.t at line 63.
#          got: 'short read (2/0) at ../lib/Image/Info/TIFF.pm line 86.
# '
#     expected: undef
Use of uninitialized value in pack at ../lib/Image/Info/TIFF.pm line 83.
Use of uninitialized value in pack at ../lib/Image/Info/TIFF.pm line 83.
# Looks like you failed 1 test of 22.
dubious
	Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 17
	Failed 1/22 tests, 95.45% okay
t/tiff.........Use of uninitialized value in pack at ../lib//Image/Info/TIFF.pm
line 83.
Use of uninitialized value in pack at ../lib//Image/Info/TIFF.pm line 83.

#   Failed test 'Right number of images found'
#   in t/tiff.t at line 19.
#          got: '1'
#     expected: '3'
Can't use an undefined value as an ARRAY reference at t/tiff.t line 22.
# Looks like you planned 12 tests but only ran 2.
# Looks like you failed 1 test of 2 run.
# Looks like your test died just after 2.
dubious
	Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 2-12
	Failed 11/12 tests, 8.33% okay
t/tiff_e.......Use of uninitialized value in pack at ../lib//Image/Info/TIFF.pm
line 83.
Use of uninitialized value in pack at ../lib//Image/Info/TIFF.pm line 83.

#   Failed test 'SamplesPerPixel is 4'
#   in t/tiff_e.t at line 26.
#          got: undef
#     expected: '4'

#   Failed test 'Width is right for the image'
#   in t/tiff_e.t at line 27.
#          got: undef
#     expected: '260'

#   Failed test 'Height is right for the image'
#   in t/tiff_e.t at line 28.
#          got: undef
#     expected: '6'
# Looks like you failed 3 tests of 10.
dubious
	Test returned status 3 (wstat 768, 0x300)
DIED. FAILED tests 3-5
	Failed 3/10 tests, 70.00% okay
----------
Comment 5 Jose Pedro Oliveira 2006-06-22 14:05:22 EDT
Created attachment 131371 [details]
Build log from Tibbs with "TEST_VERBOSE=1"
Comment 6 Jose Pedro Oliveira 2006-07-18 13:45:29 EDT
Fixed in upstream Image::Info 1.22.

---
2006-07-16 v1.22 Tels 123 tests
  * fix bug #19071: byteorder for TIFF on 64-bit systems broken
---

https://rt.cpan.org/Public/Bug/Display.html?id=19071

Note You need to log in before you can comment on or make changes to this bug.