Bug 19350 - cyradm will not work from binary rpm
cyradm will not work from binary rpm
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: cyrus-imapd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 19:24 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 07:47:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-18 19:24:59 EDT
running cyradm gives the following errors:

#cyradm localhost
Can't load
'/usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/Cyrus/IMAP/IMAP.so' for
module Cyrus::IMAP: undefined symbol: SSL_write at
/usr/lib/perl5/5.6.0/i386-linux/DynaLoader.pm line 200.
 at /usr/lib/perl5/site_perl/5.6.0/i386-linux/Cyrus/IMAP/Admin.pm line
43
Compilation failed in require at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Cyrus/IMAP/Admin.pm line 43.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Cyrus/IMAP/Admin.pm line 43.
Compilation failed in require at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Cyrus/IMAP/Shell.pm line 58.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Cyrus/IMAP/Shell.pm line 58.
Compilation failed in require.
BEGIN failed--compilation aborted.

Solution I found was to remove one of the patches rom the source rpm and recompile

1. Get the source rpm for cyrus-imapd, its on the same powertools cd
and ends .src.rpm

2. Install it rpm -i cyrus-imapd-2.0.6-3.src.rpm

This installs the source code and patches in /usr/src/redhat/

3. go to the directory /usr/src/redhat/SPECS. There is a file there
called something like cyrus-imap.spec (sorry the machine is at home, I
am at work). Edit that dfile by commenting out the two lines relating
to Patch 3 , they look like this after editing:

#Patch3: cyrus-imapd-2.0.6-nossl.patch
...
#%patch3 -p1 -b .nossl

4. In the same SPECS directory execute rpm -ba cyrus.imap.spec (or
whatever the filename is)

5 This will rebuild the sources and leave a binary rpm in
/usr/src/redhat/RPMS/i386

6. make sure you have uninstalled the old rpm and then install the one
you just built.

cyradm now works
Comment 1 Nalin Dahyabhai 2000-11-06 14:46:47 EST
This is fixed in cyrus-imapd-2.0.7-2 in Raw Hide.  Thanks!
Comment 2 Nalin Dahyabhai 2000-11-06 14:47:09 EST
*** Bug 20326 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.